Mailinglist Archive: opensuse-bugs (3543 mails)

< Previous Next >
[Bug 718025] New: amavisd-new 2.7.0 fails to start
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 15 Sep 2011 10:55:40 +0000
  • Message-id: <bug-718025-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=718025

https://bugzilla.novell.com/show_bug.cgi?id=718025#c0


Summary: amavisd-new 2.7.0 fails to start
Classification: openSUSE
Product: openSUSE.org
Version: unspecified
Platform: Other
OS/Version: SLES 11
Status: NEW
Severity: Normal
Priority: P5 - None
Component: 3rd party software
AssignedTo: opensuse-communityscreening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: bernhard.schmidt@xxxxxxxxxxxxxxx
QAContact: opensuse-communityscreening@xxxxxxxxxxxxxxxxxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101
Firefox/6.0.2

After upgrading amavisd-new from 2.6.6 to 2.7.0 in the server-mail OBS
repository amavisd-new fails to start

lxmhs44:~ # /etc/init.d/amavis start
/usr/sbin/amavis-milter not installed
lxmhs44:~ # /etc/init.d/amavis stop
/usr/sbin/amavis-milter not installed

This is caused by these lines in /etc/init.d/amavis

test -x $AMAVIS_MILTER_BIN || { echo "$AMAVIS_MILTER_BIN not installed";
if [ "$1" = "stop" ]; then exit 0;
else exit 5; fi; }

amavisd-milter is NOT included in 2.7.0 anymore, the package is broken.

Reproducible: Always

Steps to Reproduce:
1. Upgrade amavisd-new from Server/Mail to 2.7.0
2. see it failing
3.
Actual Results:
2.7.0 is broken, the old instance is not stopped and it cannot be restartet

Expected Results:
2.7.0 works

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >