Mailinglist Archive: opensuse-bugs (3542 mails)

< Previous Next >
[Bug 715854] Segmentation fault in xmlmerge when building a package

https://bugzilla.novell.com/show_bug.cgi?id=715854

https://bugzilla.novell.com/show_bug.cgi?id=715854#c2


Bruno Friedmann <bruno@xxxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Priority|P5 - None |P2 - High
CC| |bruno@xxxxxxxxxxx

--- Comment #2 from Bruno Friedmann <bruno@xxxxxxxxxxx> 2011-09-03 18:07:42 UTC
---
2.4.10 has just broke everything (almost) in factory today.

here a backtrace for pulseaudio

gdb pulseaudio
GNU gdb (GDB) SUSE (7.3-40.1)
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-suse-linux".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/pulseaudio...Reading symbols from
/usr/lib/debug/usr/bin/pulseaudio.debug...done.
done.
(gdb) run
Starting program: /usr/bin/pulseaudio
warning: no loadable sections found in added symbol-file system-supplied DSO at
0x7ffff7ffa000
[Thread debugging using libthread_db enabled]
process 27553 is executing new program: /usr/bin/pulseaudio

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff4bbac81 in ?? ()
(gdb) bt
#0 0x00007ffff4bbac81 in ?? ()
#1 0x00007fffffffd8f0 in ?? ()
#2 0x00007ffff7deb4da in _dl_check_map_versions (map=0x7ffff46a2040,
verbose=0, trace_mode=0) at dl-version.c:300
#3 0x00007ffff7ddf47e in dl_main (phdr=<optimized out>, phnum=<optimized out>,
user_entry=<optimized out>, auxv=<optimized out>) at rtld.c:2315
#4 0x00007ffff7defcf4 in _dl_sysdep_start (start_argptr=<optimized out>,
dl_main=0x7ffff7dde250 <dl_main>) at ../elf/dl-sysdep.c:244
#5 0x00007ffff7de0d63 in _dl_start_final (arg=0x7fffffffdb80) at rtld.c:336
#6 _dl_start (arg=0x7fffffffdb80) at rtld.c:562
#7 0x00007ffff7ddd648 in _start () from /lib64/ld-linux-x86-64.so.2
#8 0x0000000000000001 in ?? ()
#9 0x00007fffffffe047 in ?? ()
#10 0x0000000000000000 in ?? ()
(gdb) quit
A debugging session is active.

Inferior 1 [process 27553] will be killed.

Quit anyway? (y or n) n
Not confirmed.
(gdb) cont
Continuing.

Program terminated with signal SIGSEGV, Segmentation fault.
The program no longer exists.
(gdb)

other kind of
[16:39] <tigerfoot> factory broken ? after upgrade this morning I get a lot of
segfault in pretty much everything like
[16:39] <tigerfoot> upowerd[26054]: segfault at b0 ip 00007f4fa99eec81 sp
00007fffe729e280 error 4 in libc-2.14.so[7f4fa98de000+185000]
[16:40] <tigerfoot> pulseaudio[11787]: segfault at b0 ip 00007fd39aed4c81 sp
00007fff87b03200 error 4 in libc-2.14.so[7fd39adc4000+185000]
[16:41] <tigerfoot> openvpn[5956]: segfault at b0 ip 00007fa04a68cc81 sp
00007fffe5b7ec10 error 4 in libc-2.14.so[7fa04a57c000+185000]
[16:42] <tigerfoot> gvfs-afc-volume[3676]: segfault at b0 ip 00007fa2bfe74c81
sp 00007fffb3dc2400 error 4 in libc-2.14.so[7fa2bfd64000+185000]


The main symptom people will see is
unable to startkde

/usr/bin/startkde: line 335: 2249 Segmentation fault LD_BIND_NOW=true
/usr/lib64/kde4/libexec/start_kdeinit_wrapper +kcminit_startup

putting a ; after LB_BIND_NOW=true solve for me the kde start.
put lot's of segfault appear a bit everywhere.

Sorry but I raise the priority.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References