Mailinglist Archive: opensuse-bugs (4068 mails)

< Previous Next >
[Bug 714826] New: Systemd does not mount /home automatically
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 29 Aug 2011 21:07:24 +0000
  • Message-id: <bug-714826-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=714826

https://bugzilla.novell.com/show_bug.cgi?id=714826#c0


Summary: Systemd does not mount /home automatically
Classification: openSUSE
Product: openSUSE 12.1
Version: Factory
Platform: x86-64
OS/Version: Other
Status: NEW
Severity: Major
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: einar@xxxxxxxxxxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux) KHTML/4.7.1 (like Gecko)
Konqueror/4.7

lb@leon:~$ rpm -qi systemd
Name : systemd
Version : 33
Release : 16.1
Architecture: x86_64
Install Date: dom 28 ago 2011 18:53:01 CEST

Using this version of systemd, on a system with a separate /home partition,
home.mount is not executed (listed as inactive - dead), thus preventing a
normal login for non root users, as the home directory is not found. This can
be prevented by executing "systemctl start home.mount" manually.

Logs are attached to this bug report.

Reproducible: Always

Steps to Reproduce:
1. Pick systemd as init system on a system with separate /home
2. Boot
3. Log in as non-root user
Actual Results:
An error about missing home directory is displayed, and login opens on /

Expected Results:
User is logged in the corresponding home directory.

uname -a
Linux leon.lan 3.1.0-rc3-1-default #1 SMP Wed Aug 24 20:39:32 UTC 2011
(e975e4b) x86_64 x86_64 x86_64 GNU/Linux

Current Factory as of 29/08/2011.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >