Mailinglist Archive: opensuse-bugs (4068 mails)

< Previous Next >
[Bug 714533] New: iwl3945 fails when certain powersave activities take place after upgrade to 2.6.37.6-0.7-default
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 27 Aug 2011 02:25:18 +0000
  • Message-id: <bug-714533-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=714533

https://bugzilla.novell.com/show_bug.cgi?id=714533#c0


Summary: iwl3945 fails when certain powersave activities take
place after upgrade to 2.6.37.6-0.7-default
Classification: openSUSE
Product: openSUSE 11.4
Version: Final
Platform: Other
OS/Version: openSUSE 11.4
Status: NEW
Severity: Major
Priority: P5 - None
Component: Network
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: cgardner@xxxxxxxx
QAContact: qa@xxxxxxx
Found By: Other
Blocker: ---


Before I upgraded to the latest maintenance kernel I never had any trouble with
my wireless network adapter.

Now that I've updated to 2.6.37.6-0.7 (default), I get this problem regularly.
It apparently happens when certain power management events take place. If I
leave my laptop for 10 minutes and the power management kicks in to turn on the
screen saver, then 5 minutes later the screen is powered off, then I come back
and try to start working again, the wireless network is hosed. I try to
restart NM, but it doesn't help. I try to restart all network services with
rcnetwork and it doesn't help. I try unload and reload the iwl3945 driver and
it doesn't help. Only rebooting seems to help.

If I keep working for hours at a time, so that power management doesn't engage,
I don't have any problem. The wireless network works fine.

And it doesn't happen every time it enters the power saving state. At this
point it appears to happen randomly. I haven't yet figured out how to readily
reproduce the problem.

I have a lenovo thinkpad T61p. It has been working great for all these years
until this latest kernel update. And a little googling has suggested that
there are some possibly known issues with more recent kernels and the iwl3945
driver. Such as Bug #701037. And
http://www.spinics.net/lists/netdev/msg134439.html

Aug 26 18:54:27 ceglaptop kernel: [ 4364.529900] iwl3945 0000:03:00.0: HARDWARE
GONE?? INTA == 0xffffffff
Aug 26 18:54:28 ceglaptop kernel: [ 4365.024090] iwl3945 0000:03:00.0: Error
sending REPLY_TX_PWR_TABLE_CMD: time out after 500ms.
Aug 26 18:54:28 ceglaptop kernel: [ 4365.024100] iwl3945 0000:03:00.0: Error
setting Tx power (-110).
Aug 26 18:54:28 ceglaptop kernel: [ 4365.524100] iwl3945 0000:03:00.0: Error
sending REPLY_TX_PWR_TABLE_CMD: time out after 500ms.
Aug 26 18:54:29 ceglaptop kernel: [ 4366.296094] iwl3945 0000:03:00.0: queue 4
stuck 3 time. Fw reload.
Aug 26 18:54:29 ceglaptop kernel: [ 4366.296102] iwl3945 0000:03:00.0: On
demand firmware reload
Aug 26 18:54:29 ceglaptop kernel: [ 4366.324132] iwl3945 0000:03:00.0: Error
sending REPLY_RXON: time out after 500ms.
Aug 26 18:54:29 ceglaptop kernel: [ 4366.324141] iwl3945 0000:03:00.0: Error
clearing ASSOC_MSK on current configuration (-110).
Aug 26 18:54:29 ceglaptop kernel: [ 4366.824103] iwl3945 0000:03:00.0: Error
sending REPLY_TX_PWR_TABLE_CMD: time out after 500ms.
Aug 26 18:54:29 ceglaptop kernel: [ 4366.828057] iwl3945 0000:03:00.0: MAC is
in deep sleep!. CSR_GP_CNTRL = 0xFFFFFFFF

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups