Mailinglist Archive: opensuse-bugs (4067 mails)

< Previous Next >
[Bug 712762] New: Kernel 3.0.X and undervolting and Pentium M (single core)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 17 Aug 2011 21:46:48 +0000
  • Message-id: <bug-712762-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=712762

https://bugzilla.novell.com/show_bug.cgi?id=712762#c0


Summary: Kernel 3.0.X and undervolting and Pentium M (single
core)
Classification: openSUSE
Product: openSUSE 11.4
Version: Final
Platform: x86
OS/Version: openSUSE 11.4
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Kernel
AssignedTo: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: d.janssen@xxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.20)
Gecko/20110804 SUSE/3.6.20-1.4 Firefox/3.6.20

I tried in vain to undervolt different Pentium M cpus with the newest kernel
(3.0.X, tumbleweed) and opensuse 11.4. Until version 2.6.39 it worked with
phc-intel, but after installing 3.0, Pentium M (on different notebooks) is not
recognized correctly by acpi-cpufreq. I debugged the patched kernel module and
found, that in acpi_cpufreq_cpu_init the detection changed from HARDWARE addr
space (2.6.39) to SYSTEM IO addr space (3.0.X). Therefore also latency is too
high, so that the system reponse seems to be slower.
I don't know, where I can change this behaviour, in which module I have to
look for the detection routine.

Reproducible: Always

Steps to Reproduce:
1.Patch acpi_cpufreq.c with phc-intel
2.
3.
Actual Results:
femto:/home/j32 # cat /sys/devices/system/cpu/cpu0/cpufreq/phc_vids
cat: /sys/devices/system/cpu/cpu0/cpufreq/phc_vids: No such device

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups