Mailinglist Archive: opensuse-bugs (4067 mails)

< Previous Next >
[Bug 581644] kernel /does not boot/ when on battery power

https://bugzilla.novell.com/show_bug.cgi?id=581644

https://bugzilla.novell.com/show_bug.cgi?id=581644#c63


--- Comment #63 from Jon Nelson <jnelson-suse@xxxxxxxxxxx> 2011-08-12 15:04:19
UTC ---
(In reply to comment #62)
I'll be modifying the patches a bit more. Would you be interested in the
changes I've made?
Definitely!

The patches are currently a bit rough, and I have tried several different
approaches. Please allow me some time to clean them up a bit, but would you
prefer to collaborate out-of-band (ie, email) on this for now? It might be
easier.

One idea I had is to copy the table data away from initrd (and get the fully
initrd memory released).
My idea for a cleaned up version was to:
- memblock_find_in_range()
- memblock_x86_reserve_range()
- copy the ACPI table(s) in there
- increase initrd_start pointer to the starting address of the real
initrd/cpio
- make sure initrd including (already copied away) ACPI tables are freed
here:
/arch/x86/mm/init.c:free_initrd_mem()

There is a acpi=copy_dsdt boot param, I wanted to have a look what they are
doing there...

Ahh. Nice. I'll look at that, as well as the above approach. I also tried
alloc_bootmem, kalloc, and a few others.


Hope this helps. I hope to be able to spend some time on this next week.

Your efforts are very much appreciated!

No, Sir, *your* efforts are very much appreciated!

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >