Mailinglist Archive: opensuse-bugs (4067 mails)

< Previous Next >
[Bug 711258] New: Setting LDAP on command line with yast2 doesn't work
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 9 Aug 2011 13:39:57 +0000
  • Message-id: <bug-711258-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=711258

https://bugzilla.novell.com/show_bug.cgi?id=711258#c0


Summary: Setting LDAP on command line with yast2 doesn't work
Classification: openSUSE
Product: openSUSE 11.4
Version: Factory
Platform: i586
OS/Version: openSUSE 11.4
Status: NEW
Severity: Normal
Priority: P5 - None
Component: YaST2
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: haukeh@xxxxxxxxxx
QAContact: jsrain@xxxxxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101
Firefox/5.0

When I run

yast2 keyboard summary
yast2 language summary

it says that "German" is set. But keyboard is still english. If I use the yast2
text gui the language is set properly.

LDAP configuration is not working too (text gui doesn't work either).

yast2 ldap pam enable server="192.168.1.2" base="dn=nodomain" tls=no
mkhomedir=yes
yast2 ldap pam enable

Reproducible: Always

Steps to Reproduce:
1. yast2 ldap pam enable server="192.168.1.2" base="dn=nodomain" tls=no
mkhomedir=yes
2. yast2 ldap pam enable
3. Try to log in with your LDAP credentials


Actual Results:
No LDAP login possible.

Expected Results:
LDAP login possible.

After reboot /etc/ldap.conf contains:

host 127.0.0.1
base dc=example,dc=com
bind_policy soft
pam_lookup_policy yes
pam_password exop
nss_initgroups_ignoreusers root,ldap
nss_schema rfc2307bis

This is not what I entered.
nss_map_attribute uniqueMember member
ssl start_tls

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >