Mailinglist Archive: opensuse-bugs (3926 mails)

< Previous Next >
[Bug 710200] New: [obs-webui] OBS can't parse _link in branched package when original one had no revision yet
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 4 Aug 2011 04:52:10 +0000
  • Message-id: <bug-710200-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=710200

https://bugzilla.novell.com/show_bug.cgi?id=710200#c0


Summary: [obs-webui] OBS can't parse _link in branched package
when original one had no revision yet
Classification: openSUSE
Product: openSUSE.org
Version: unspecified
Platform: Other
OS/Version: Other
Status: NEW
Severity: Minor
Priority: P5 - None
Component: BuildService
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: stoyan.dimkov@xxxxxxxxx
QAContact: adrian@xxxxxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=444006)
--> (http://bugzilla.novell.com/attachment.cgi?id=444006)
screenshot of branch package bug

User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.1 (KHTML,
like Gecko) Chrome/13.0.782.109 Safari/535.1

When user branches a fresh new package and goes to sources gets greeted by an
error message saying "Files could not be expanded: _link is bad: bad revision
'empty'".

Reproducible: Always

Steps to Reproduce:
1. Create a new package.
2. Branch the brand new package.
3. Open tab "Sources" of the branch.
Actual Results:
The sources tab opens normally but a flash message appears with the following
error "Files could not be expanded: _link is bad: bad revision 'empty'".

Expected Results:
OBS should be able to parse _link file even when revision has value 'empty'.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >