Mailinglist Archive: opensuse-bugs (4671 mails)

< Previous Next >
[Bug 628298] api.o.o flakes out when remote bs_srcserver requests
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 20 Sep 2010 12:02:25 +0000
  • Message-id: <20100920120225.3476BCC7D3@xxxxxxxxxxxxxxxxxxxxxx>

https://bugzilla.novell.com/show_bug.cgi?id=628298

https://bugzilla.novell.com/show_bug.cgi?id=628298#c6


--- Comment #6 from Jan Engelhardt <jengelh@xxxxxxxxxx> 2010-09-20 12:02:24 UTC
---
According to /proc/sys/net, tcp_keepalive_intvl is 75. However, running tcpdump
on my end shows that no ACKs are sent within more than 5 minutes.

/proc/net/tcp contains

sl local_address rem_address st tx_queue rx_queue tr tm->when retrnsmt
uid timeout inode
27: 864C5305:B173 C387DD21:01BB 01 00000000:00000000 02:0000B112 00000000
403 0 34891101 2 fffff801ce8dd500 22 4 1 3 2
29: 864C5305:CCDC C387DD21:01BB 01 00000000:00000000 02:000037A8 00000000
403 0 34889329 2 fffff801ed464700 23 4 8 4 12
32: 864C5305:CC75 C387DD21:01BB 01 00000000:00000000 02:00002E40 00000000
403 0 34889234 2 fffff801ed461aa0 22 4 7 3 2
33: 864C5305:D794 C387DD21:01BB 01 00000000:00000000 02:0001E4F5 00000000
403 0 34892072 2 fffff801ed6e61a0 22 4 6 2 2

Since the timer is closing in on the magic boundary of 2 hours, I'll wait a few
sec:

# rcobssrcserver status
R 7164 23866 GET
/getprojpack?withsrcmd5&withdeps&withrepos&withconfig&arch=x86_64&project=Black_Ares:11.3&package=844-ksc-pcf&package=Botan&package=CASA&package=CASA-kwallet&package=CASA_auth_token_client&package=CASA_auth_token_server&package=CASA_auth_t
running
13:59:48.330402 IP 134.76.83.5.52341 > 195.135.221.33.443: Flags [.], ack
3525918430, win 92, length 0

# rcobssrcserver status
R 7247 23866 GET
/getprojpack?withsrcmd5&withdeps&withrepos&withconfig&arch=x86_64&project=Black_Ares:11.3&package=844-ksc-pcf&package=Botan&package=CASA&package=CASA-kwallet&package=CASA_auth_token_client&package=CASA_auth_token_server&package=CASA_auth_t


So that makes three things. Keepalives are being sent, but very few, api.o.o
does not respond to them, and my connection remains.

I don't even know of the TCB still exists on api.o.o.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >