Mailinglist Archive: opensuse-bugs (4667 mails)

< Previous Next >
[Bug 640336] network:dhcp: Init script "rc.dhcpd" not fully LSB compliant
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 20 Sep 2010 08:33:36 +0000
  • Message-id: <20100920083336.93FFC245523@xxxxxxxxxxxxxxxxxxxxxx>

https://bugzilla.novell.com/show_bug.cgi?id=640336

https://bugzilla.novell.com/show_bug.cgi?id=640336#c2


Marius Tomaschewski <mt@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |NEEDINFO
Version|unspecified |Final
InfoProvider| |ro@xxxxxxxxxx
Component|3rd party software |Other
CC| |radmanic@xxxxxxx,
| |werner@xxxxxxxxxx
Product|openSUSE.org |openSUSE 11.3

--- Comment #2 from Marius Tomaschewski <mt@xxxxxxxxxx> 2010-09-20 08:33:35 UTC
---
OK,
the codes 5 and 6 are reserved by LSB in status and the dhcpd binary started
by the service before may, still run.

When a service gets uninstalled, the service is stopped and the binary _and_
the init script removed via rpm scripts.

The easiest (only?) way to trigger the problem is to just remove the config
file without to stop/uninstall the service.

Question is, if this is a bug -- that exists in any service / init script we
ship as well as in /etc/init.d/skeleton, or it has to be resolved as INVALID
[WONTFIX] because it is incorrect use similar to e.g. a "chmod -x $binary" ?

RĂ¼diger, Werner, what do you say?

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >
References