Mailinglist Archive: opensuse-bugs (4671 mails)

< Previous Next >
[Bug 640391] New: executing grub in shellscript executed from withing a makefile results in a bus error
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 19 Sep 2010 11:56:16 +0000
  • Message-id: <bug-640391-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>

https://bugzilla.novell.com/show_bug.cgi?id=640391

https://bugzilla.novell.com/show_bug.cgi?id=640391#c0


Summary: executing grub in shellscript executed from withing a
makefile results in a bus error
Classification: openSUSE
Product: openSUSE 11.3
Version: Final
Platform: x86-64
OS/Version: openSUSE 11.3
Status: NEW
Severity: Critical
Priority: P5 - None
Component: Development
AssignedTo: pth@xxxxxxxxxx
ReportedBy: xanclic@xxxxxxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=390382)
--> (http://bugzilla.novell.com/attachment.cgi?id=390382)
Shellscript which executes grub and makefile which executes the script

User-Agent: Opera/9.80 (X11; Linux x86_64; U; de) Presto/2.6.30
Version/10.61

After I updated my kernel (among other updates) today, I tried to build the
project I'm working on (which is an operating system). The makefile I use
executes a shellscript to create a floppy disk image which in turn calls grub
to install grub on that image — this worked fine until yesterday, but after
today's update I get a bus error everytime I execute grub in that shellscript
(except when executing “grub --help”). If I call the script directly (without
makefile), it works just fine.

Reproducible: Always

Steps to Reproduce:
1. Unpack the attached archive anywhere.
2. The first file it contains is a script called “make_image.sh”. This will
create a FAT formatted floppy disk image, copy stage1 and stage2 from
/boot/grub there and run grub on it.
3. The second file is a makefile, which simply runs that script.
4. Now type “make” or “./make_image.sh” and compare.
Actual Results:
When using make, GRUB crashes with a bus error. When directly executing the
shellscript, it doesn't and a FAT formatted floppy disk image with a well
installed GRUB is the result.

Expected Results:
GRUB should not crash in either of both cases.

As said before, I ran the YaST online update some hours ago which included a
kernel update.

The versions of the used programs are:
kernel — 2.6.34.7-0.2 (desktop)
make — 3.81 (built for x86_64-unknown-linux-gnu)
bash — 4.1.7(1)-release (built for x86_64-suse-linux-gnu)
grub — 0.97
mtools — 4.0.13


(note: I set the serverity to “critical”, because the software obviously
crashes — imho this is just a normal bug, but the description of “critical”
told me it isn't)

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >