Mailinglist Archive: opensuse-bugs (4671 mails)

< Previous Next >
[Bug 640375] New: Extreme system slowdown when using ondemand governor with cpu-intensive task
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 19 Sep 2010 05:32:12 +0000
  • Message-id: <bug-640375-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>

https://bugzilla.novell.com/show_bug.cgi?id=640375

https://bugzilla.novell.com/show_bug.cgi?id=640375#c0


Summary: Extreme system slowdown when using ondemand governor
with cpu-intensive task
Classification: openSUSE
Product: openSUSE 11.3
Version: Final
Platform: x86-64
OS/Version: openSUSE 11.3
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Kernel
AssignedTo: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: arysin@xxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.10)
Gecko/20100914 SUSE/3.6.10-3.1 Firefox/3.6.10

I have Dell Studio 15 and using ondemand governor. When compiling kdelibs and
kdebase the system switches to max frequency but at some point (withing
minutes) it drops to the min frequency and the whole system gets extremely slow
(much slower than usually at min frequency).

It may stay this way for a while and then may jump back to max frequency and
then within couple of minutes to go back to slowdown.

Same happens with openSUSE 11.3 and 11.4 (milestone 1).

I must not I have R600 graphics chip on the laptop and using open-source
drivers. when running the compilation the system gets quite hot - the VGA
connector is quite hot to touch (even though temp sensors don't report
temperature too high 66-80°C).

I am curious if the radeon hardware/driver combined with high temperature
limits the cpu frequencies somehow.


Reproducible: Always

Steps to Reproduce:
1. Switch to ondemand cpu governor
2. Start compiling kdelibs

Actual Results:
within minutes see cpu freq goes to min and the system is extremely
unresponsive

Expected Results:
System should stay at max frequency when running cpu-intensive tasks.

Cpu is Intel(R) Core(TM)2 Duo CPU T8100 @ 2.10GHz

I must note two things: I see same results when using Mandriva 2010.1 with
open-source ati driver but I think (but can't be sure) I haven't seen this with
2010.0 and fglrx.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >
This Thread
  • No further messages