Mailinglist Archive: opensuse-bugs (4671 mails)

< Previous Next >
[Bug 640355] New: zypper's install-new-recommends selects packages that don't seem to be recommended by anything
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 18 Sep 2010 15:28:14 +0000
  • Message-id: <bug-640355-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>

https://bugzilla.novell.com/show_bug.cgi?id=640355

https://bugzilla.novell.com/show_bug.cgi?id=640355#c0


Summary: zypper's install-new-recommends selects packages that
don't seem to be recommended by anything
Classification: openSUSE
Product: openSUSE 11.3
Version: Final
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: libzypp
AssignedTo: zypp-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: cmorve69@xxxxxxxx
QAContact: qa@xxxxxxx
Found By: Community User
Blocker: ---


Created an attachment (id=390364)
--> (http://bugzilla.novell.com/attachment.cgi?id=390364)
Solver test case

A "zypper inr" run tries to install:

flash-player kdebase4-nsplugin nspluginwrapper pullin-flash-player

The fact that pullin-flash-player is selected is already suspicious. But the
thing is that following
http://stick.gk2.sk/blog/2010/03/zypper-dependency-graph/ I can't see why any
of them are triggered for installation ("Needed by" tabs are empty).

Adding any combination of three of them to /var/lib/zypp/SoftLocks still
triggers the installation of the fourth one.


So, there is at least a problem: there is no way to know why the packages are
selected. And then there seems to be another one, either there is a problem in
the pullin-flash-player package (that still doesn't explain why
kdebase4-nsplugin is selected) or there is a bug in the solver. Perhaps the
first problem is explained by such a solver's bug.


Solver test case attached.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >