Mailinglist Archive: opensuse-bugs (4667 mails)

< Previous Next >
[Bug 627065] Configuration of Wacom Intuos 2 Serial kills X.org input
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 15 Sep 2010 14:44:01 +0000
  • Message-id: <20100915144401.7FE2D24551D@xxxxxxxxxxxxxxxxxxxxxx>

https://bugzilla.novell.com/show_bug.cgi?id=627065

https://bugzilla.novell.com/show_bug.cgi?id=627065#c19


Robert Forsyth <robert.forsyth3@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |robert.forsyth3@xxxxxxxxxx

--- Comment #19 from Robert Forsyth <robert.forsyth3@xxxxxxxxxx> 2010-09-15
14:44:00 UTC ---
I have found that the serial port (ttyS0 or ttyUSB0) works differently in 11.3,
but I think this is a change lower down. For example the serial connected
Garmin GPS no longer sends data to the host computer; the fix for this is to
disable modem controls with stty -F /dev/ttyUSB0 9600 clocal - I've not yet
found a way to make this happen automatically. I'm assuming the X server hangs
waiting for input from the Wacom serial pad.

If someone could explain how to run the equivalent to "stty -F /dev/ttyS0
clocal" before the X server starts, I can test if this is the solution to non
working serial Wacoms in 11.3

I have a non working in 11.3 Wacom Intuos serial pad, if you enable it in
xorg.conf, on restarting the X server, it just stops working.

(In reply to comment #0)
Created an attachment (id=379591)
--> (http://bugzilla.novell.com/attachment.cgi?id=379591) [details]
modified /etc/X11/xorg.conf.d/20-wacom.conf

User-Agent: Mozilla/5.0 (compatible; Konqueror/4.3; Linux) KHTML/4.3.5
(like Gecko) SUSE

When I configure my Intuos 2 Serial (not USB!), the complete X11 input devices
can't be used anymore (touchpad and keyboard). The tablet itselve also doesn't
work.


Reproducible: Always

Steps to Reproduce:
1. Add the attached 20-wacom.conf into /etc/X11/xorg.conf.d (you needn't add a
grphics tablet, it also happens when nothing is attached)
2. Restart X

Actual Results:
keyboard, mouse and so on will no longer work, ssh access over netword works

Expected Results:
X should work like before and wacom tablet should also be useable

(In reply to comment #17)
It worked with 11.2 on my ASUS notebook, where it doesn't work now with 11.3.
I
do not have logfiles from the time I've used 11.2 on it and I don't want to
reinstall for a simple Xorg.0.log, so I've taken the Xorg.0.log from my Dell
notebook where still 11.2 is installed (and will stay as long I can't use the
tablet). It also doesn't depend on the Serial-USB Adapter, I also can
reproduce
the problem on a PentiumII with 11.3 and a serial port.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >