Mailinglist Archive: opensuse-bugs (4667 mails)

< Previous Next >
[Bug 639396] New: Won't boot inside openvz container because of the permissions /etc/init.d/boot mount devpts with.
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 14 Sep 2010 22:54:17 +0000
  • Message-id: <bug-639396-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>

https://bugzilla.novell.com/show_bug.cgi?id=639396

https://bugzilla.novell.com/show_bug.cgi?id=639396#c0


Summary: Won't boot inside openvz container because of the
permissions /etc/init.d/boot mount devpts with.
Classification: openSUSE
Product: openSUSE 11.3
Version: Final
Platform: Other
OS/Version: openSUSE 11.3
Status: NEW
Severity: Enhancement
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: rob.fortune@xxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/534.7
SUSE/7.0.513.0 (KHTML, like Gecko) Chrome/7.0.513.0 Safari/534.7

System fails to boot because the pts are unavailable to the host system.

Reproducible: Always

Steps to Reproduce:
1. Get a VPS in OpenVZ
2. Try and boot it
3.
Actual Results:
Boot fails, can't login with "fake serial console" either because it can't get
a pty

Expected Results:
Boot to work.

Here are the changes I made to /etc/init.d/boot to make it work. You could add
detection for being run under openvz and mount devpts differently.


--- boot.orig 2010-09-15 06:46:45.000000000 +0000
+++ boot 2010-09-15 06:03:35.000000000 +0000
@@ -24,8 +24,9 @@
#
# Standard input from the system console
#
-test -z "$CONSOLE" && CONSOLE=/dev/console
REDIRECT="$(showconsole 2>/dev/null)"
+CONSOLE="$REDIRECT"
+#test -z "$CONSOLE" && CONSOLE=/dev/console
export CONSOLE REDIRECT

#
@@ -96,16 +97,16 @@
fi
fi

-DTYPE=$(stat -f -c "%T" /dev 2>/dev/null)
-if test "$DTYPE" != "tmpfs" ; then
- echo -n "Mounting devtmpfs at /dev"
- mount -n -t $DEVTMPFS -o mode=0755 $DEVTMPFS /dev
- rc_status -v -r
-fi
-
-echo -n "Copying static /dev content"
-cp -axT --remove-destination /lib/udev/devices /dev
-rc_status -v -r
+#DTYPE=$(stat -f -c "%T" /dev 2>/dev/null)
+#if test "$DTYPE" != "tmpfs" ; then
+# echo -n "Mounting devtmpfs at /dev"
+# mount -n -t $DEVTMPFS -o mode=0755 $DEVTMPFS /dev
+# rc_status -v -r
+#fi
+
+#echo -n "Copying static /dev content"
+#cp -axT --remove-destination /lib/udev/devices /dev
+#rc_status -v -r

if test "$(stat -Lc %d /dev/shm 2>/dev/null)" = "$(stat -Lc %d /dev/shm/..
2>/dev/null)" ; then
echo -n "Mounting tmpfs at /dev/shm"
@@ -118,14 +119,14 @@
if test "$DTYPE" != "devpts" ; then
echo -n "Mounting devpts at /dev/pts"
mkdir -p -m 755 /dev/pts
- mount -n -t devpts -o mode=0620,gid=5 devpts /dev/pts
+ mount -n -t devpts -o defaults devpts /dev/pts
rc_status -v -r
fi

#
# Set I/O of this script and its childs to console
#
-exec 0<> $CONSOLE 1>&0 2>&0
+#exec 0<> $CONSOLE 1>&0 2>&0

#
# Should we ask for interactive boot mode

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups