Mailinglist Archive: opensuse-bugs (4669 mails)

< Previous Next >
[Bug 612413] intel [GM45] Xserver crash when switching from clone to extended screen mode (Assertion in libdrm)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 1 Sep 2010 08:48:58 +0000
  • Message-id: <20100901084858.12486CC7D2@xxxxxxxxxxxxxxxxxxxxxx>

https://bugzilla.novell.com/show_bug.cgi?id=612413

https://bugzilla.novell.com/show_bug.cgi?id=612413#c27


Stefan Dirsch <sndirsch@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|ASSIGNED |NEEDINFO
InfoProvider| |wstephenson@xxxxxxxxxx

--- Comment #27 from Stefan Dirsch <sndirsch@xxxxxxxxxx> 2010-09-01 08:48:57
UTC ---
(In reply to comment #26)
At a quik test it seems that the crash is fixed.

Ok.

In some cases xorg still crash but i can currend not verify that it is not bug
597078.

Bug #597078 is not a crash (ie not a segfault or assertion), but a freeze. So
are you really talking about a crash?

But there are some other bugs at the screen switching that it leve it
unuseable.
- In some cases the resulution of the Leptop LCD is switched to the external
resulution (not clone mode)
- xrandr did not detect the highest resulution of the external screen.
- In some cases i have only a half screen visible (LCD or external not both)
mouse works on the full screen.

IMHO seperate issues should be handled in seperate bugreports. Otherwise bugs
can never be closed.

- The KDE desktop moved to the external screen. But this seems to be KDE
relatet so i will report it there.

I guess so as well.

Will, can you confirm that the libdrm assertion is fixed now? But make sure
you disable desktop effects. Otherwise it's rather likely that the Xserver
crashes immediately during login. :-(

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >