Mailinglist Archive: opensuse-bugs (4669 mails)

< Previous Next >
[Bug 627504] zypper 1.4.5 ignores allowVendorChange
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 1 Sep 2010 08:00:36 +0000
  • Message-id: <20100901080037.01D9724551D@xxxxxxxxxxxxxxxxxxxxxx>

https://bugzilla.novell.com/show_bug.cgi?id=627504

https://bugzilla.novell.com/show_bug.cgi?id=627504#c5


Ján Kupec <jkupec@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEEDINFO |RESOLVED
InfoProvider|jw@xxxxxxxxxx |
Resolution| |INVALID

--- Comment #5 from Ján Kupec <jkupec@xxxxxxxxxx> 2010-09-01 08:00:35 UTC ---
c#3: good eye Michael! :O) Juergen, i'll close this report now. If it was more
than just a type, please reopen it.

c#4: there are only the two possibilities: either put a vendor file for that
repo's vendor to /etc/zypp/vendors.d just like you did above, or ignore vendor
checking completely by setting the solver.allowVendorChange = true (which is
probably not a good idea as a default).

As for the previous releases, IIRC the vendor locking works like this since the
introduction of sat solver in 11.0. Are you sure it worked in 11.x? If you feel
there's a bug or we should improve something, yes, please open a new bug
report.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >