Mailinglist Archive: opensuse-bugs (4766 mails)

< Previous Next >
[Bug 599503] New: [KDE:KDE4:Community/webkam]
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 25 Apr 2010 15:00:09 +0000
  • Message-id: <bug-599503-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=599503

http://bugzilla.novell.com/show_bug.cgi?id=599503#c0


Summary: [KDE:KDE4:Community/webkam]
Classification: openSUSE
Product: openSUSE.org
Version: unspecified
Platform: Other
OS/Version: openSUSE 11.2
Status: NEW
Severity: Critical
Priority: P5 - None
Component: 3rd party software
AssignedTo: opensuse-communityscreening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: roger@xxxxxx
QAContact: opensuse-communityscreening@xxxxxxxxxxxxxxxxxxxxxx
Found By: Community User
Blocker: Yes


Two problems really:

1. The rpm does not have a dependency for ruby-gstreamer and ruby-glib2. As a
result the app does not start, printing:

/usr/lib/ruby/vendor_ruby/1.8/gst.rb:2:in `require': no such file to load --
glib2 (LoadError)
from /usr/lib/ruby/vendor_ruby/1.8/gst.rb:2
from ./webkam_app.rb:2:in `require'
from ./webkam_app.rb:2
from main.rb:1:in `require'
from main.rb:1

After adding these it starts.

2: This is the real problem: taking a photo causes the app to crash. When it
crashes, it prints:

/webcam_video_stream.rb:175:in `save_frame': undefined method `data' for
nil:NilClass (NoMethodError)
from ./photo_page.rb:103:in `save_photo'
from ./photo_page.rb:97:in `loop'
from ./photo_page.rb:97:in `save_photo'
from ./photo_page.rb:63:in `initialize'
from /usr/lib/ruby/site_ruby/1.8/Qt/qtruby4.rb:2361:in `call'
from /usr/lib/ruby/site_ruby/1.8/Qt/qtruby4.rb:2361:in `invoke'
from /usr/lib/ruby/site_ruby/1.8/Qt/qtruby4.rb:441:in `qt_metacall'
from /usr/lib/ruby/site_ruby/1.8/Qt/qtruby4.rb:441:in `method_missing'
from /usr/lib/ruby/site_ruby/1.8/Qt/qtruby4.rb:441:in `exec'
from ./webkam_app.rb:45:in `run'
from main.rb:3

It finds my USB webcam ok (ID 046d:c019 Logitech, Inc. Optical Tilt Wheel
Mouse). And the cam works in other apps.

I am using this rpm: webkam-0.3.2-2.3.i586

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
This Thread
  • No further messages