Mailinglist Archive: opensuse-bugs (4760 mails)

< Previous Next >
[Bug 597774] New: installation on second of three disks fails to boot
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 19 Apr 2010 13:37:39 +0000
  • Message-id: <bug-597774-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=597774

http://bugzilla.novell.com/show_bug.cgi?id=597774#c0


Summary: installation on second of three disks fails to boot
Classification: openSUSE
Product: openSUSE 11.3
Version: Milestone 5
Platform: i586
OS/Version: openSUSE 11.3
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Bootloader
AssignedTo: juhliarik@xxxxxxxxxx
ReportedBy: fehr@xxxxxxxxxx
QAContact: jsrain@xxxxxxxxxx
Found By: Development
Blocker: ---


My test installation to try to reproduce bug #597723 failed with a problem
a think is related to yast2-bootloader.

I have three disks in my system and did a installation to the second disk
(/dev/sdb). Installation went through without a problem but initial boot
failed.
Created /boot/grub/menu.lst was the following:
---------------------------------------------------------------------------
default 0
timeout 8
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 11.3 - 2.6.34-rc3-3
kernel (hd0,1)/boot/vmlinuz-2.6.34-rc3-3-desktop
root=/dev/disk/by-id/ata-SA
MSUNG_SP2504C_S09QJ1LL613911-part2 disk=64000
resume=/dev/disk/by-id/ata-SAMSUNG
_SP2504C_S09QJ1LL613911-part1 splash=silent quiet showopts vga=0x317
initrd (hd0,1)/boot/initrd-2.6.34-rc3-3-desktop

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.3 - 2.6.34-rc3-3
kernel (hd0,1)/boot/vmlinuz-2.6.34-rc3-3-desktop
root=/dev/disk/by-id/ata-SA
MSUNG_SP2504C_S09QJ1LL613911-part2 showopts apm=off noresume nosmp maxcpus=0
edd
=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset
x11fai
lsafe vga=0x317
initrd (hd0,1)/boot/initrd-2.6.34-rc3-3-desktop

###Don't change this comment - YaST2 identifier: Original name: openSUSE 11.2
-
2.6.31.12-0.2 (/dev/sda2)###
title openSUSE 11.2 - 2.6.31.12-0.2 (/dev/sda2)
root (hd0,1)
configfile /boot/grub/menu.lst

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,0)
chainloader +1
---------------------------------------------------------------------------
devices.map was the following:
---------------------------------------------------------------------------
(hd2) /dev/disk/by-id/ata-SAMSUNG_SP2504C_S09QJ1LL613911
(hd1) /dev/disk/by-id/ata-SAMSUNG_SP2504C_S09QJ1LL613912
(hd0) /dev/disk/by-id/ata-SAMSUNG_HD160JJ_P_S0DFJ1NL701257
---------------------------------------------------------------------------

After changing all references for "hd0" in first two boot entries to "hd2"
booting worked find. Strange is how devices.map is different to 11.2
which is:
(hd0) /dev/sda
(hd1) /dev/sdb
(hd2) /dev/sdc
Udev id in 11.2 are:
/dev/sda ata-SAMSUNG_HD160JJ_P_S0DFJ1NL701257
/dev/sdb ata-SAMSUNG_SP2504C_S09QJ1LL613911
/dev/sdc ata-SAMSUNG_SP2504C_S09QJ1LL613912

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >