Mailinglist Archive: opensuse-bugs (4724 mails)

< Previous Next >
[Bug 593971] Grub root= incorrect with 2 SCSI controllers
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 9 Apr 2010 06:42:35 +0000
  • Message-id: <20100409064235.D7579245467@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=593971

http://bugzilla.novell.com/show_bug.cgi?id=593971#c3


Jiri Srain <jsrain@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |NEEDINFO
InfoProvider| |mludvig@xxxxxxxxxxxx

--- Comment #3 from Jiri Srain <jsrain@xxxxxxxxxx> 2010-04-09 06:42:35 UTC ---
The bugs are probably different:

ad Michal: I guess this is a result of initialization of the SCSI adapters
and/or disks in different order during installation and during boot of
installed system. The solution is not to mount devices by name, but rather use
by-id or by-label. I'm afraid that this is the only way to prevent such
situations. Is there any reason not to use it?

ad Alberto: As long as the device names are correct, what's wrong in your case
is the mapping between the disks. The installer can only guess the order of the
disks (as it depends on your BIOS settings, which is different once you boot
from CD). That's why you have the possibility to review the disks order. There
is hardly anything we can do about it.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References