Mailinglist Archive: opensuse-bugs (4692 mails)

< Previous Next >
[Bug 593608] New: YaST2 ISDN: UI Syntax Error - Multiple buttons with role [Cancel]
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 3 Apr 2010 23:16:51 +0000
  • Message-id: <bug-593608-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=593608

http://bugzilla.novell.com/show_bug.cgi?id=593608#c0


Summary: YaST2 ISDN: UI Syntax Error - Multiple buttons with
role [Cancel]
Classification: openSUSE
Product: openSUSE 11.2
Version: Final
Platform: x86-64
OS/Version: openSUSE 11.2
Status: NEW
Severity: Normal
Priority: P5 - None
Component: YaST2
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: tilman@xxxxxxx
QAContact: jsrain@xxxxxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=352341)
--> (http://bugzilla.novell.com/attachment.cgi?id=352341)
y2logs

User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.1.8)
Gecko/20100204 SUSE/3.5.8-0.1.1 Firefox/3.5.8

Configuring an ISDN adapter in YaST2 with WANTED_GUI="qt" and LANG=de_DE.UTF-8,
after confirming the installation of the required package "kinternet", a
message box with orange red background pops up:

/-------------------------------------\
| YaST2 (als Administrator) |
|-------------------------------------|
| UI Syntax Error |
| Multiple buttons with role [Cancel] |
| Check the log file! |
| [Close] |
\-------------------------------------/

After clicking the Close button, another message box appears:

/----------------------------------------------\
| YaST2 (als Administrator) |
|----------------------------------------------|
| Erforderliche Pakete sind nicht installiert. |
| Die Konfiguration wird abgebrochen. |
| Erneuter Versuch? |
| [Nein] [Ja] |
\----------------------------------------------/

("Required packages are not installed. The configuration will be aborted. Try
again? Yes / No".)

Klicking the Yes button redisplays the "following packages must be installed"
message. Confirming that produces the "UI Syntax Error" message again.

Klicking the No button writes a configuration file
/etc/sysconfig/isdn/cfg-contr0, ie. the configuration is _not_ aborted, but the
adapter does not show up in "cinternet -I".

Reproducible: Always

Steps to Reproduce:
1. Start YaST2.
2. Click the "ISDN" icon in the "Network Devices" section.
3. On the "ISDN Configuration Overview" page, "ISDN Devices" tab, select a
(the) controller and click the Edit button.
4. On the "ISDN Low Level Configuration for contrcontr0" (sic!) page, modify
some setting and click Ok.
5. Back on the "ISDN Configuration Overview" page, click Ok again.
6. On the message box saying "The following packages must be installed:
kinternet", click Install.


Actual Results:
A red message box appears, saying:

UI Syntax Error
Multiple buttons with role [Cancel]
Check the log file!

Package kinternet is not installed.
The command "cinternet -I" does not list any interfaces.

Expected Results:
No error message, ISDN adapter showing up as available in cinternet.

y2logs attached. I'd like to mention that the hotkey combination Shift/F8
advertised in
http://en.opensuse.org/Bugs/YaST#I_reported_a_YaST2_bug.2C_and_now_I_am_asked_to_.22attach_y2logs.22._What_does_that_mean.2C_and_how_do_I_do_that.3F
does _not_ work, so I used the save_y2logs shell command.

After the attempt, /var/log/messages contains several instances of the
apparently related message:

Apr 4 00:40:05 xenon network: has unknown interface type. Please file a bug
report.

Manually installing kinternet via YaST2 - "Install or Remove Software" worked
fine, pulling in 77 MiB of KDE3 dependencies with it. After that, the UI error
message is gone, but the error message in /var/log/messages still appears, and
the interface still doesn't show up in "cinternet -I".

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >