Mailinglist Archive: opensuse-bugs (4724 mails)

< Previous Next >
[Bug 589994] gpg incurs problem at encryption, returns error code 2, breaks scripts
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 1 Apr 2010 16:00:34 +0000
  • Message-id: <20100401160034.5BEA6CC7CE@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=589994

http://bugzilla.novell.com/show_bug.cgi?id=589994#c6


--- Comment #6 from Alex Tsariounov <alext@xxxxxxxxxx> 2010-04-01 16:00:33 UTC
---
(In reply to comment #5)
(In reply to comment #4)
It is reproducible. I think this may be interference from seahorse-agent.

It is. Seahorse-agent does not fully implement the gpg-agent interface.

Perhaps running gpg-agent somehow makes gpg stop trying to connect to
seahorse-agent, and it doesn't try to connect even after gpg-agent is
killed?
Yes, that's how gpg-agent works. See echo $GPG_AGENT_INFO - this is set both
by gpg-agent and seahorse-agent.

Makes sense.

gpg2-2.0.14-3.1.x86_64
This is not gpg2 version included in 'official 11.2' repositories. Please try
to install gpg2-2.0.12 - with this version, I was no longer able to reproduce
the issue.

Strange, I've not installed gpg2 specifically, just got it via the 11.2 repos
and updates. Perhaps one of the other repos slid this in somehow. Aha, looks
like it came from openSUSE:Tools:

[zuul:Desktop]$ s zypper info gpg2
Loading repository data...
Reading installed packages...
Information for package gpg2:
Repository: @System
Name: gpg2
Version: 2.0.14-3.1
Arch: x86_64
Vendor: obs://build.opensuse.org/openSUSE:Tools

I get the latest osc from Tools. Is there a way to set that specific packages
only get installed from specific repos?

Thanks.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >