Mailinglist Archive: opensuse-bugs (4691 mails)

< Previous Next >
[Bug 582135] update breaks wlan setup
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 26 Feb 2010 19:52:36 +0000
  • Message-id: <20100226195236.CC52524551B@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=582135

http://bugzilla.novell.com/show_bug.cgi?id=582135#c4


Harald Koenig <koenig@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|CLOSED |REOPENED
Resolution|WORKSFORME |

--- Comment #4 from Harald Koenig <koenig@xxxxxxxx> 2010-02-26 19:52:35 UTC ---
(In reply to comment #3)
(In reply to comment #2)
updating 11.1 shall not break a funcional wlan setup...

Right.

more info: I'm always using traditional network setup, no Network Manager
(also, not an option;)

Yes. Unfortunately. Try wpa_gui from the wpa_supplicant_gui rpm.

installed (it's wpa_supplicant-gui for the cut'n'paste records).

it does not show any adapter nor network. in the starting xterm there is this
msg every second:

PING failed - trying to reconnect


more tracing shows:
get_iface_type() in scripts/functions returns "eth" for my wlan0 device
because
/sys/class/net/wlan0/wireless does not exist:

I am afraid there must be some misconfiguration in your system. I have
upgraded

which type of "misconfiguration" do you expect being able to influence the
contents of /sys/class/net/wlan0/ ?
I guess that's directly kernel-only stuff, or am I wrong here ?!
what else in y "configuration shall I check ?

the 11.1 with Intel 4965 to 2.6.27.42 [1] either and I can see no problems on
my system [2]. The ifup/ifdown works as expected [3]. I have to close as
WORKSFORME, but reopen if you feel that I can help you anyway.

[1]
# uname -a
Linux dolby 2.6.27.42-0.1-default

32 or 64 bit ? I'm running 64bit (see plattform in ticket).

to my surprise(?) modinfo shows:

harald > /sbin/modinfo iwlagn | grep filename
filename:
/lib/modules/2.6.27.42-0.1-default/weak-updates/updates/drivers/net/wireless/iwlwifi/iwlagn.ko


harald > ll
/lib/modules/2.6.27.42-0.1-default/weak-updates/updates/drivers/net/wireless/iwlwifi/iwlagn.ko
lrwxrwxrwx 1 root root 81 Feb 23 01:10
/lib/modules/2.6.27.42-0.1-default/weak-updates/updates/drivers/net/wireless/iwlwifi/iwlagn.ko
->
/lib/modules/2.6.27.39-0.2-default/updates/drivers/net/wireless/iwlwifi/iwlagn.ko

harald > ll -L
/lib/modules/2.6.27.42-0.1-default/weak-updates/updates/drivers/net/wireless/iwlwifi/iwlagn.ko
-rw-r--r-- 1 root root 220720 Dec 1 21:18
/lib/modules/2.6.27.42-0.1-default/weak-updates/updates/drivers/net/wireless/iwlwifi/iwlagn.ko

harald > md5sum
/lib/modules/2.6.27.42-0.1-default/weak-updates/updates/drivers/net/wireless/iwlwifi/iwlagn.ko
da2d80a429d588d87d10b548e8859002
/lib/modules/2.6.27.42-0.1-default/weak-updates/updates/drivers/net/wireless/iwlwifi/iwlagn.ko

harald > dmesg | grep iwlwifi-4965
firmware: requesting iwlwifi-4965-2.ucode

does this match your setup ?



[2]
# ll /sys/class/net/wlan0/wireless/
total 0

harald > ll /sys/class/net/wlan0/wireless/
ls: cannot access /sys/class/net/wlan0/wireless/: No such file or directory


[3]
BOOTPROTO='dhcp'

diff between your ifcfg-* and mine:

diff ifcfg-yours /etc/sysconfig/network/ifcfg-wlan0
3a4
IFPLUGD_PRIORITY='10'
6c7
< NAME='PRO/Wireless 4965 AG or AGN [Kedron] Network Connection'
---
NAME='PRO/Wireless 4965 AG or AGN Network Connection'
23c24
< WIRELESS_ESSID='test-ap'
---
WIRELESS_ESSID='foo'
39c40,41
< WIRELESS_WPA_PSK='passwd'
---
WIRELESS_WPA_PSK='bar'
WIRELESS=yes


the "WIRELESS=yes" is new -- the rest of this setup worked rock solid at least
for opensuse 11.0/11.1/11.2 with the last 3 generations of intel wlan chips

about the different $NAME: are we using same chip revisions ?
yours does not mention "[Kedron]"

I can't find a non-Kedron in pci.ids though:

harald > grep "4965 AG" /usr/share/pci.ids
4229 PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
4230 PRO/Wireless 4965 AG or AGN [Kedron] Network Connection


my pci ids:

harald > /sbin/lspci -s 03:00.0 -n
03:00.0 0280: 8086:4230 (rev 61)
harald > /sbin/lspci -s 03:00.0 -v
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN
[Kedron] Network Connection (rev 61)
Subsystem: Intel Corporation Lenovo ThinkPad T61
Flags: bus master, fast devsel, latency 0, IRQ 4343
Memory at df2fe000 (64-bit, non-prefetchable) [size=8K]
Capabilities: <access denied>
Kernel driver in use: iwlagn
Kernel modules: iwlagn



other ideas ?!

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References