Mailinglist Archive: opensuse-bugs (4691 mails)

< Previous Next >
[Bug 582135] update breaks wlan setup
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 26 Feb 2010 08:16:52 +0000
  • Message-id: <20100226081652.B61CF24551B@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=582135

http://bugzilla.novell.com/show_bug.cgi?id=582135#c3


Vladimir Botka <vbotka@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|ASSIGNED |CLOSED
Resolution| |WORKSFORME

--- Comment #3 from Vladimir Botka <vbotka@xxxxxxxxxx> 2010-02-26 08:16:51 UTC
---
(In reply to comment #2)
updating 11.1 shall not break a funcional wlan setup...

Right.

more info: I'm always using traditional network setup, no Network Manager
(also, not an option;)

Yes. Unfortunately. Try wpa_gui from the wpa_supplicant_gui rpm.

more tracing shows:
get_iface_type() in scripts/functions returns "eth" for my wlan0 device
because
/sys/class/net/wlan0/wireless does not exist:

I am afraid there must be some misconfiguration in your system. I have upgraded
the 11.1 with Intel 4965 to 2.6.27.42 [1] either and I can see no problems on
my system [2]. The ifup/ifdown works as expected [3]. I have to close as
WORKSFORME, but reopen if you feel that I can help you anyway.

[1]
# uname -a
Linux dolby 2.6.27.42-0.1-default

[2]
# ll /sys/class/net/wlan0/wireless/
total 0
-r--r--r-- 1 root root 4096 2010-02-25 14:31 beacon
-r--r--r-- 1 root root 4096 2010-02-25 14:31 crypt
-r--r--r-- 1 root root 4096 2010-02-25 14:31 fragment
-r--r--r-- 1 root root 4096 2010-02-25 14:31 level
-r--r--r-- 1 root root 4096 2010-02-25 14:31 link
-r--r--r-- 1 root root 4096 2010-02-25 14:31 misc
-r--r--r-- 1 root root 4096 2010-02-25 14:31 noise
-r--r--r-- 1 root root 4096 2010-02-25 14:31 nwid
-r--r--r-- 1 root root 4096 2010-02-25 14:31 retries
-r--r--r-- 1 root root 4096 2010-02-25 14:31 status


[3]
BOOTPROTO='dhcp'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME='PRO/Wireless 4965 AG or AGN [Kedron] Network Connection'
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='yes'
WIRELESS_AP=''
WIRELESS_AUTH_MODE='psk'
WIRELESS_BITRATE='auto'
WIRELESS_CA_CERT=''
WIRELESS_CHANNEL=''
WIRELESS_CLIENT_CERT=''
WIRELESS_CLIENT_KEY=''
WIRELESS_CLIENT_KEY_PASSWORD=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_EAP_AUTH=''
WIRELESS_EAP_MODE=''
WIRELESS_ESSID='test-ap'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0=''
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_PEAP_VERSION=''
WIRELESS_POWER='yes'
WIRELESS_WPA_ANONID=''
WIRELESS_WPA_IDENTITY=''
WIRELESS_WPA_PASSWORD=''
WIRELESS_WPA_PSK='passwd'

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References