Mailinglist Archive: opensuse-bugs (4691 mails)

< Previous Next >
[Bug 581341] Encrypted swap not allowed unless it is formatted during install
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 24 Feb 2010 17:17:57 +0000
  • Message-id: <20100224171757.C53AACC7D1@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=581341

http://bugzilla.novell.com/show_bug.cgi?id=581341#c9


--- Comment #9 from Thomas Fehr <fehr@xxxxxxxxxx> 2010-02-24 17:17:56 UTC ---
Would of course be doable and would also not be too complicated to implement.

Nevertheless it would cause potentially more password popups than currently:

Current state:
- User is prompted for a password if and only if he explicitely manipulates
(format or setup) a encrypted volume. This is what is to be expected and
nobody should be surprised. Disadvantag: since without the password we c
annot know about the content of the volume, we have to accept less comfort
in some areas.

Your suggested change:
- User is prompted for a password whenever yast2 finds a volume containing a
LUKS signature that has no accompanying crypt dm table. This is unexpected.
Maybe the user simply wants to do something that does not involve
manipulation
of any encrypted volume at all. I do not think this is really much better
than the current state.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References