Mailinglist Archive: opensuse-bugs (4691 mails)

< Previous Next >
[Bug 582135] New: update breaks wlan setup
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 23 Feb 2010 10:37:03 +0000
  • Message-id: <bug-582135-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=582135

http://bugzilla.novell.com/show_bug.cgi?id=582135#c0


Summary: update breaks wlan setup
Classification: openSUSE
Product: openSUSE 11.1
Version: Final
Platform: x86-64
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Update Problems
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: koenig@xxxxxxxx
QAContact: jsrain@xxxxxxxxxx
Found By: ---
Blocker: ---


Lenovo T61p notebook with i4965AGN wlan (iwlagn driver). my wlan setup with
WPA2/PSK always worked fine, until yesterday...

running "zypper patch" to get recent updates (last update was on Feb 07) broke
my wlan setup, connection to my AP didn't work anymore. among many other
packets (237 changed/new RPMs) the kernel changed from 2.6.27.39-0.2-de to
2.6.27.42-0.1-de.


after some tests I found the following (knowing similar problems from RALINK
wlan driver problems):

- adding WIRELESS=yes in ifcfg-wlan0 "fixes" the problem, wlan works again.

- WIRELESS=yes is needed because after "ifconfig wlan0 down" wlan does not show
up anymore in /proc/net/wireless (can't test the old behaviour right now -- at
least for ralink on SLES10 this was the same problem -- and the same fixed
worked there and here;)


either wlan drivers shall not unregister from /proc/net/wireless if interface
is down, or suse wlan-scripts must not use /proc/net/wireless as information to
detect/handle wlan startup...

is this a wlan driver bug or a "feature" that wlan0 does not show up in
/proc/net/wireless ? so far I considered this a ralink bug, but now that tie
iwlagn driver suddenly behaves the same.... ?!??

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >