Mailinglist Archive: opensuse-bugs (4691 mails)

< Previous Next >
[Bug 581652] New: installer should never unset boot flags on otherwise untouched primary partitions
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 22 Feb 2010 03:10:49 +0000
  • Message-id: <bug-581652-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=581652

http://bugzilla.novell.com/show_bug.cgi?id=581652#c0


Summary: installer should never unset boot flags on otherwise
untouched primary partitions
Classification: openSUSE
Product: openSUSE 11.3
Version: Factory
Platform: PC
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Installation
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: mrmazda@xxxxxxxxxxxxx
QAContact: jsrain@xxxxxxxxxx
Found By: ---
Blocker: ---


y2_logs: https://bugzilla.novell.com/attachment.cgi?id=262841

I deselected everything in install bootloader because there was no way to
select to install to the only place I wanted the installer to touch, / on
/dev/md3 (sda10 & sdb10). I didn't want anything already working to be
disturbed by a new additional installation. Those deselects included "set
active flag". The result was "no operating system found" on first real reboot.

Unchecking the active flag box should never mean removing all flags from all
primary partitions if Grub or Lilo are not installed on the MBR in place of
generic MBR code. In this case, the only touching of any primary partitions was
supposed to be simply to mount them. The / target was a logical. Therefore, the
installer should not have touched any part of the MBR on any disk.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >