Mailinglist Archive: opensuse-bugs (4691 mails)

< Previous Next >
[Bug 581318] New: kupdateapplet produces error concerning kdesu
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 19 Feb 2010 16:46:25 +0000
  • Message-id: <bug-581318-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=581318

http://bugzilla.novell.com/show_bug.cgi?id=581318#c0


Summary: kupdateapplet produces error concerning kdesu
Classification: openSUSE
Product: openSUSE 11.2
Version: Final
Platform: x86-64
OS/Version: openSUSE 11.2
Status: NEW
Severity: Normal
Priority: P5 - None
Component: KDE4 Applications
AssignedTo: kde-maintainers@xxxxxxx
ReportedBy: thomas.ludwig@xxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=343517)
--> (http://bugzilla.novell.com/attachment.cgi?id=343517)
Updater Applet error

User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de-DE; rv:1.9.2.0)
Gecko/20100115 SUSE/3.6.0-1.2 Firefox/3.6

I'm using KDE 4.4. All KDE packages are from the KDE Factory repo.
I've installed kupdateapplet-zypp, selected Zypp in the Updater Applet settings
and "Show available upgrades when backend provides them (for experts only)" in
order to make its behavior consistent with zypper up.

Now every time when the Applet reports available updates and I install them via
the Applet, I get the error shown in the attachment.

The updates are nevertheless installed correctly according to
/var/log/zypp/history, and zypper up doesn't show any updates anymore. The
Applet symbol changed to a yellow warning triangle which vanishes after
advising it to search for updates again.

In ~/.xsession-errors I found the following entries:

[code]
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: Incremental parsing error.
buffer size: 31
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: "error triggered by
consumer"
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: Incremental parsing error.
buffer size: 124
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: "error triggered by
consumer"
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: Incremental parsing error.
buffer size: 63
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: "error triggered by
consumer"
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: Incremental parsing error.
buffer size: 61
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: "error triggered by
consumer"
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: Incremental parsing error.
buffer size: 124
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: "error triggered by
consumer"
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: Incremental parsing error.
buffer size: 118
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: "error triggered by
consumer"
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: Incremental parsing error.
buffer size: 64
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: "error triggered by
consumer"
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: Incremental parsing error.
buffer size: 76
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: "error triggered by
consumer"
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: Incremental parsing error.
buffer size: 62
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: "error triggered by
consumer"
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: Incremental parsing error.
buffer size: 10
kupdateapplet(3556) ZYppUpdater::slotHelperStdout: "error triggered by
consumer"
kdesud(7287) ConnectionHandler::doCommand: Command completed: "( xargs zypper
--no-cd -x --non-interactive in -l -t patch --name <
/tmp/kupdateapplet.jKe2Xb6hEX/kupdateapplet_patch ; xargs zypper --no-cd -x
--non-interactive in -l -t package --name <
/tmp/kupdateapplet.jKe2Xb6hEX/kupdateapplet_package ) >
/tmp/kupdateapplet.jKe2Xb6hEX/kupdateapplet_out 2>
/tmp/kupdateapplet.jKe2Xb6hEX/kupdateapplet_err "
kupdateapplet(3556) ZYppUpdater::slotInstallProcessExited: install process
exited.
kupdateapplet(3556) Logics::disableAutoSuspend: . disableAutoSuspend set to:
false
kupdateapplet(3556) Logics::disableAutoSuspend: ! disableAutoSuspend not
implemented yet
kupdateapplet(3556) Logics::dumpUpdateLists: . ----- package, patch and driver
list --------------------
kupdateapplet(3556) Logics::dumpUpdateLists: . ----- end of package, patch and
driver list -------------
kupdateapplet(3556)/kdeui (kdelibs) QWidgetStackAccelManager::currentChanged:
invalid index provided
kupdateapplet(3556) Logics::selectedPatches: # selected patches: 0
kupdateapplet(3556) Logics::selectedPackages: # selected packages: 0
kupdateapplet(3556) Logics::slotAppletError: ! applet error: "kdesu(7275)
KDESu::PtyProcess::exec: [
/usr/src/packages/BUILD/kdelibs-4.4.0/kdesu/process.cpp : 295 ] Running
"/bin/su"
kdesu(7275) KDESu::SuProcess::ConverseSU: [
/usr/src/packages/BUILD/kdelibs-4.4.0/kdesu/su.cpp : 259 ] Read line
"Password: "
kdesu(7275) KDESu::PtyProcess::exec: [
/usr/src/packages/BUILD/kdelibs-4.4.0/kdesu/process.cpp : 295 ] Running
"/bin/su"
kdesu(7275) KDESu::SuProcess::ConverseSU: [
/usr/src/packages/BUILD/kdelibs-4.4.0/kdesu/su.cpp : 259 ] Read line
"Password: "
kdesu(7275) KDESu::PtyProcess::WaitSlave: [
/usr/src/packages/BUILD/kdelibs-4.4.0/kdesu/process.cpp : 381 ] Child pid 7282
kdesu(7275) KDESu::SuProcess::ConverseSU: [
/usr/src/packages/BUILD/kdelibs-4.4.0/kdesu/su.cpp : 259 ] Read line ""
kdesu(7275) KDESu::SuProcess::ConverseSU: [
/usr/src/packages/BUILD/kdelibs-4.4.0/kdesu/su.cpp : 259 ] Read line
"kdesu_stub"
[/code]

I had also renamed the file ~/.kde4/share/config/kdebugrc . It was recreated
after performing an update with the Applet and contained the following lines:

[code]
[kbuildsycoca4]
InfoOutput=2

[kdecore (services)]
InfoOutput=2

[kdesu (kdelibs)]
InfoOutput=2
[/code]

Reproducible: Always

Steps to Reproduce:
1.Configure the Updater Applet as described.
2.Perform an update with the Applet.
3.Install the available updates/patches.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups