Mailinglist Archive: opensuse-bugs (4691 mails)

< Previous Next >
[Bug 581276] New: zypper dup --from does not downgrade packages
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 19 Feb 2010 13:54:34 +0000
  • Message-id: <bug-581276-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=581276

http://bugzilla.novell.com/show_bug.cgi?id=581276#c0


Summary: zypper dup --from does not downgrade packages
Classification: openSUSE
Product: openSUSE 11.2
Version: Final
Platform: x86
OS/Version: openSUSE 11.2
Status: NEW
Severity: Normal
Priority: P5 - None
Component: libzypp
AssignedTo: zypp-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: ctrippe@xxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=343465)
--> (http://bugzilla.novell.com/attachment.cgi?id=343465)
solverTestCase from zypper dup --from

User-Agent: Mozilla/5.0 (compatible; Konqueror/4.4; Linux) KHTML/4.4.0
(like Gecko) SUSE

I wanted to update to the lasted KDE packages from the KDE Factory repo of the
buildservice.

For this I used 'zypper -v dup --from KDE4' and was surprised that it did not
want to install synaptiks which is new in that repo and I had it installed
before from another repo.

So I tried 'zypper -v dup -r KDE4' and found compared to the first command that
zypper now wants to downgrade some packages which was not the case with
'--from', see list below

Die folgenden Pakete werden durch eine ältere Version ausgetauscht:
kbluetooth 0.4.RC2-2.10 -> 0.4-5.2
kipi-plugins 1.1.0-52.2 -> 1.1.0-50.12
kipi-plugins-lang 1.1.0-52.2 -> 1.1.0-50.12
libqt4 4.6.2-98.1 -> 4.6.2-2.1
libqt4-debuginfo 4.6.2-98.1 -> 4.6.2-2.1
libqt4-devel 4.6.2-98.1 -> 4.6.2-2.1
libqt4-qt3support 4.6.2-98.1 -> 4.6.2-2.1
libqt4-sql 4.6.2-98.1 -> 4.6.2-2.1
libqt4-sql-sqlite 4.6.2-98.1 -> 4.6.2-2.1
libqt4-x11 4.6.2-98.1 -> 4.6.2-2.1
libqt4-x11-debuginfo 4.6.2-98.1 -> 4.6.2-2.1
libQtWebKit4 4.6.2-98.1 -> 4.6.2-2.1
libQtWebKit-devel 4.6.2-98.1 -> 4.6.2-2.1
synaptiks 0.3.2-1.10 -> 0.3.2-1.8
synaptiks-debuginfo 0.3.2-1.10 -> 0.3.2-1.8


So I conclude 'zypper dup --from' does not downgrade packages (any longer)

christian@asterix:~> rpm -qa | grep zypp
libzypp-6.21.2-1.1.1.i586
zypper-1.2.8-0.1.3.i586

I attach the solver test case generated by 'zypper dup --debug-solver --from
KDE4'

Reproducible: Always

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >