Mailinglist Archive: opensuse-bugs (4688 mails)

< Previous Next >
[Bug 580217] Deskjet F2400 series devices not supported by the HPLIP version in openSUSE
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 17 Feb 2010 22:36:41 +0000
  • Message-id: <20100217223641.37A0124551B@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=580217

http://bugzilla.novell.com/show_bug.cgi?id=580217#c10


--- Comment #10 from Dirk Förster <dfoerster@xxxxxxxx> 2010-02-17 22:36:39 UTC
---
(In reply to comment #8)
Confusion:

On http://hplipopensource.com I clicked "Download HPLIP",
answered the question as if I had a Deskjet f2410 all-in-one
and got this information:
--------------------------------------------------------------------
Installation Wizard
You have selected SUSE Linux 11.2 using
the HP Deskjet f2410 All-in-one Printer.

SUSE Linux 11.2 supplies HPLIP 3.9.8
and it does support your printer.

As the version of HPLIP supplied with
your operating system supports your printer,
you may continue to use that version of HPLIP.

You may now optionally download the latest version
of HPLIP to get access to new features and bug fixes.
--------------------------------------------------------------------

I asked HP regarding this confusion:
https://answers.launchpad.net/hplip/+question/101394
Let's wait what they answer there.



# hp-chek -t

Produces a neat log.

Interesting to me was:

a) HP Device 0x7611 at 001:002:
Device URI: hp:/usb/Deskjet_F2400_series?serial=CN98C172JX05H4
error: Unsupported model: Deskjet_F2400_series

b) A lot of packages are missing and need to be installed. The report gives
detailed information of what to enter.The package manager solves dependencies
by loading additional packages from repositories. I ran # hp-check -t a couple
of times to check progress.

Some examples are:

Summary of needed commands to run to satisfy missing dependencies:
su -c "zypper --non-interactive --no-gpg-checks in --auto-agree-with-licenses
dbus-1-devel python-gobject2"
su -c "zypper --non-interactive --no-gpg-checks in --auto-agree-with-licenses
gcc-c++"
su -c "zypper --non-interactive --no-gpg-checks in --auto-agree-with-licenses
libjpeg-devel"
su -c "zypper --non-interactive --no-gpg-checks in --auto-agree-with-licenses
net-snmp-devel"
su -c "zypper --non-interactive --no-gpg-checks in --auto-agree-with-licenses
libtool libgphoto2-devel"
su -c "zypper --non-interactive --no-gpg-checks in --auto-agree-with-licenses
libusb-devel libusb-1_0-0"
su -c "zypper --non-interactive --no-gpg-checks in --auto-agree-with-licenses
python-imaging"
su -c "zypper --non-interactive --no-gpg-checks in --auto-agree-with-licenses
python-devel python-xml"

Having installed all required packages, it still holds true what the remaining
error messages states: Unsupported model: Deskjet_F2400_series.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >
References