Mailinglist Archive: opensuse-bugs (4687 mails)

< Previous Next >
[Bug 568481] radeonhd/radeon [HD 4650] Blank screen
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 16 Feb 2010 01:11:07 +0000
  • Message-id: <20100216011107.3FECC24551B@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=568481

http://bugzilla.novell.com/show_bug.cgi?id=568481#c12


--- Comment #12 from Damien Mfaransa <dm@xxxxxxxxxxxxxxx> 2010-02-16 01:11:06
UTC ---
After playing around further, I can confirm once again that the issue is fixed
in the current xf86-video-ati from git.

Didn't try "radeonhd", since "radeon" actually provides all the needed features
for r600/r700.

A bit offtopic, here is the setup i'll recommend from Opensuse 11.2 on an
R600/700 chip :

- switch to latest Xorg (1.7.xx)/Mesa from repo :
http://download.opensuse.org/repositories/X11:/XOrg/

- switch to HEAD kernel from repo :
http://download.opensuse.org/repositories/Kernel:/HEAD/

- upgrade libdrm and install drm-all-kmp + kernel-firmware from :
http://download.opensuse.org/repositories/home:/jobermayr/
This will enable kernel modesetting, now very stable and soon probably the only
way to go for graphics drivers.

- use latest xf86-video-ati from git
it's the only way to get LVDS working anyway.

- Make sure xorg.conf contains under Device Section :
Driver "radeon"
Option "MigrationHeuristic" "greedy"
Somehow migrationheuristic=greedy still gives better performance than the
default "always".

This way I've got now a very pleasant desktop experience. (with KDE4 kwin
compositing in my case)

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
This Thread
  • No further messages