Mailinglist Archive: opensuse-bugs (4654 mails)

< Previous Next >
[Bug 577799] New: Recovery tool in DVD fails.
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 7 Feb 2010 21:05:47 +0000
  • Message-id: <bug-577799-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=577799

http://bugzilla.novell.com/show_bug.cgi?id=577799#c0


Summary: Recovery tool in DVD fails.
Classification: openSUSE
Product: openSUSE 11.2
Version: Final
Platform: x86-64
OS/Version: openSUSE 11.2
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Maintenance
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: carlos.e.r@xxxxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


I had a broken boot, because I had mistakenly replaced the kernel files in
/boot from the files of a 32 bit install. I just needed to reinstall the
kernel, and the repair tool (retail DVD) failed.

First I tried the expert mode (third option). I specified I wanted to check the
database of installed packages. I identified the partition (1 of 3), it
identified the kernel files, reinstalled them... and failed, because it did not
mount the /boot partition first. I tried to mount manually /boot and retry, but
it was useless, because the procedure umounts / and all.

I then rebooted the dvd and tried the semi-expert option. I clicked the box for
package database, and it itself marked filesystem check and more - a waste of
time, because the filesystem was correct. Worse, it insisted on "repairing"
fstab, which was completely correct. I said to ignore lines, and clicked the
button "skip". It popped another window insisting on correcting fstab (I don't
have a photo): it wanted to replace some lines, and again I said "skip".
Finally, package recovery failed, I forgot why (and there is no log that I
know): the thing is that fstab was broken as a result (I have copies of fstab
before and later, with missing lines).


In the end, I had to make a backup of my files, and reinstall 11.2 from the
retail DVD.

I had another problem with grub on another partition. I needed to reinstall
grub, and the recovery tool failed, too. YaST also failed to reinstall grub.
The grub command line also failed. Again, I had to do a full reinstall of 11.2,
and then recover my files from a backup. Happened twice to me this weekend.


Your recovery tool on the DVD is useless.
On both problems, several occasions on a single weekend.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups