Mailinglist Archive: opensuse-bugs (4664 mails)

< Previous Next >
[Bug 577732] New: Laptop does not come back after s2ram !
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 6 Feb 2010 05:02:24 +0000
  • Message-id: <bug-577732-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=577732

http://bugzilla.novell.com/show_bug.cgi?id=577732#c0


Summary: Laptop does not come back after s2ram !
Classification: openSUSE
Product: openSUSE 11.2
Version: Final
Platform: i586
OS/Version: openSUSE 11.2
Status: NEW
Severity: Major
Priority: P5 - None
Component: Kernel
AssignedTo: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: s_samar@xxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4)
Gecko/20091016 SUSE/3.5.4-1.1.2 Firefox/3.5.4

Hi Developer,
s2ram does not seem to be working properly on my HCL laptop. After running
s2ram the machine does not come back at all, nething the graphics nor the
keyboard or device connected to it seems responding. I have to hard boot only
to bring it back. (I am not sure the following is related - "Even if the
machine is plugged into the AC power, it does not come back after restart. I
have to plug it off from the AC power and poweron.")

My machine is not a whilelist machine for s2ram. The output of s2ram -n is:

# s2ram -n
Machine unknown
This machine can be identified by:
sys_vendor = "HCL Infosystems Limited"
sys_product = "T12C "
sys_version = "1.0 "
bios_version = "208 "
See http://en.opensuse.org/S2ram for details.

The output of lspci is :
# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual
PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO]
(rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller
(rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller
(rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit
Ethernet Adapter (rev 02)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE
mode (rev 03)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:0d.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b4)
00:0d.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 09)
00:0d.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host
Adapter (rev 18)
00:0d.3 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 09)
00:0d.4 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter
(rev ff)
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671
PCIE VGA Display Adapter (rev 10)
02:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless
Network Adapter (rev 01)

----------------------
The s2disk also creates problem. After recovering from the hibernate, the
network card does not respond, I have to reload the network driver all the way.
And the laptop does not hibernate again after one recovery from hibernate,
without and intermediate reboot of the machine.

May be this will help making opensuse better....

Regards,
Samar


Reproducible: Always

Steps to Reproduce:
1. run s2ram -f -p -m , or run echo mem > /sys/power/state

Actual Results:
The system suspends and hangs after an attempt to recover it from the suspend.
Neither the keboard, graphics nor any other device seems responding.

Expected Results:
The system should come back to the original state .


The s2disk also creates problem. After recovering from the hibernate, the
network card does not respond, I have to reload the network driver all the way.
And the laptop does not hibernate again after one recovery from hibernate,
without and intermediate reboot of the machine.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >