Mailinglist Archive: opensuse-bugs (4664 mails)

< Previous Next >
[Bug 576540] New: boot process: several issues with(out) ACPI (no scanner, no serial port, no floppy ...)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 3 Feb 2010 15:28:41 +0000
  • Message-id: <bug-576540-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=576540

http://bugzilla.novell.com/show_bug.cgi?id=576540#c0


Summary: boot process: several issues with(out) ACPI (no
scanner, no serial port, no floppy ...)
Classification: openSUSE
Product: openSUSE 11.2
Version: Final
Platform: i586
OS/Version: openSUSE 11.2
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: kunsche@xxxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1)
Gecko/2008070208 Firefox/3.0.1 (.NET CLR 3.5.30729)

First of all I filed parts of these issues earlier (see bug #570473) but in the
mean time some more issues occurred, so it seems to be a more general issue
with the boot process. OK, here's the whole story:

When ACPI is enabled on my somewhat outdated 32 bit PIII board (GA-6va7+)
everything is fine. But as this board is fully equipped with hardware (which
partly doesn't allow to share interrupts) I need the Interrupt that is normally
occupied by the ACPI controller. Therefore I have to switch it off (ACPI=off at
boot prompt). This now causes several issues, like that no floppy device
(/dev/fd0) is generated, the execution of the boot.clock script failed (that’s
the already filed bug) and the parallel port is not working (here one can see
faulty interrupts) and last (but probably) not least the usb scanner doesn't
work (this is an Printer/Scanner combination, where the printing functionality
is still available).
This behaviour was verified with the following kernels:
2.6.31.5-default, 2.6.31.8-default, 2.6.31.8-pae , 2.6.31.8-vanilla ,
2.6.32.41-default (from ...Kernel:/HEAD/openSUSE_11.2/i586)
By the way, switching of parallel booting by setting the sysconfig variable
PARALLELL=no gave no difference.

To say it again, when ACPI is enabled there are none of these issues (except
that the GPIB card isn't usable as the ACPI controller occupies the interrupt).
Please have a look at the output of cat /proc/interrupts

############## acpi=on ####################
CPU0
0: 36891 XT-PIC-XT timer
1: 85 XT-PIC-XT i8042
2: 0 XT-PIC-XT cascade
3: 1 XT-PIC-XT
4: 1 XT-PIC-XT
5: 0 XT-PIC-XT ni_atmio
6: 7 XT-PIC-XT floppy
7: 78 XT-PIC-XT parport0
8: 0 XT-PIC-XT rtc0
9: 0 XT-PIC-XT acpi
10: 430 XT-PIC-XT ohci_hcd:usb2, ohci_hcd:usb3, ohci1394,
EMU10K1, eth0, eth1
11: 16372 XT-PIC-XT ehci_hcd:usb1, ivtv0, nvidia
12: 1821 XT-PIC-XT i8042
14: 16133 XT-PIC-XT pata_via
15: 708 XT-PIC-XT pata_via
..
MCP: 1 Machine check polls
ERR: 0
MIS: 0

############## acpi=off ####################
CPU0
0: 79162 XT-PIC-XT timer
1: 43 XT-PIC-XT i8042
2: 0 XT-PIC-XT cascade
3: 1 XT-PIC-XT
4: 1 XT-PIC-XT
5: 0 XT-PIC-XT ni_atmio
7: 292 XT-PIC-XT
8: 0 XT-PIC-XT rtc0
9: 0 XT-PIC-XT atgpib
10: 430 XT-PIC-XT ohci_hcd:usb2, ohci_hcd:usb3, ohci1394,
EMU10K1, eth0, eth1
11: 34501 XT-PIC-XT ehci_hcd:usb1, ivtv0, nvidia
12: 1925 XT-PIC-XT i8042
14: 15252 XT-PIC-XT pata_via
15: 1017 XT-PIC-XT pata_via
..
MCP: 2 Machine check polls
ERR: 292
MIS: 0

Prior distributions on this system (SuSE 8.2 , openSUSE 10.2 , 10.3 and 11.1)
never had these problems. Using openSUSE 11.1 with an 2.6.32.41-default kernel
(from ...Kernel:/HEAD/openSUSE_11.1/i586) also indicated no problem, so the
described issues seems not to be kernel related, but a weakness of the boot
process.

Maybe one should also have a look at bug#576095, it's not triggered by ACPI on
or off, but it seems also be related to the boot process.


Reproducible: Always

Steps to Reproduce:
1. switch off ACPI with the kernel parameter acpi=off at the boot prompt
2.
3.
Actual Results:
parallel port not working, boot.clock script failed, no /dev/fd0 generated, usb
scanner doesn't work

Expected Results:
functionality of the floppy, scanner and parallel port should not depend on the
usage of ACPI

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >