Mailinglist Archive: opensuse-bugs (4653 mails)

< Previous Next >
[Bug 575730] New: QuickPlay hotheys buttons not work in HP Pavillion dv6315 laptop
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 1 Feb 2010 14:56:41 +0000
  • Message-id: <bug-575730-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=575730

http://bugzilla.novell.com/show_bug.cgi?id=575730#c0


Summary: QuickPlay hotheys buttons not work in HP Pavillion
dv6315 laptop
Classification: openSUSE
Product: openSUSE 11.2
Version: Final
Platform: Other
OS/Version: openSUSE 11.2
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Mobile Devices
AssignedTo: mobile-bugs@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: embar@xxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=339951)
--> (http://bugzilla.novell.com/attachment.cgi?id=339951)
"xmodmap -pke" output

User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; lt; rv:1.9.2.0)
Gecko/20100115 SUSE/3.6.0-1.2 Firefox/3.6

HP Pavillion dv6315ea laptop has multimedia hotkeys. There are two special
buttons for QuickPlay. The first one has similar symbol to Q.; another – DVD.

In openSUSE 10.2 and 10.3 it worked fine.
In openSUSE 10.3
the first Q. button, e008, was recognized as "Launch C",
the second DVD button, e00e, was recognized as "Media".

Since openSUSE 11.0 these buttons not worked,
but after manually installing hotkey-setup package
and executing /etc/init.d/hotkey-setup restart,
it worked.

The bad think is that hotkey-setup was droped since 11.0
https://bugzilla.novell.com/show_bug.cgi?id=398846 .
This functionality should by controlled by hal, but it don't do it.

I filled a bug in freedesktop
http://bugs.freedesktop.org/show_bug.cgi?id=19936 ,
there was made a patch
http://cgit.freedesktop.org/hal-info/diff/fdi/information/10freedesktop/30-keymap-hp.fdi?id=eba65779cd95716706912707db297d389fecf8e5
but it didn't helped.

Maybe this bug is somehow related also to these:
https://bugzilla.novell.com/show_bug.cgi?id=398774
https://bugzilla.novell.com/show_bug.cgi?id=398846
https://bugzilla.novell.com/show_bug.cgi?id=524734

xev didn't react to these buttons.

showkey didn't react to Q. button (e008),
but DVD button (e00e) recognized as 389.

Then I open /var/log/messages, I see:
Feb 1 15:38:39 dv6315ea kernel: [ 98.932694] atkbd.c: Unknown key released
(translated set 2, code 0x88 on isa0060/serio0).
Feb 1 15:38:39 dv6315ea kernel: [ 98.932700] atkbd.c: Use 'setkeycodes e008
<keycode>' to make it known.

output of "setxkbmap -print":
xkb_keymap {
xkb_keycodes { include "evdev+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include
"pc+us+lt(std):2+inet(evdev)+level3(ralt_switch)+eurosign(e)" };
xkb_geometry { include "microsoft(natural)" };
};



Reproducible: Always

Steps to Reproduce:
1. have openSUSE 11.X
2. try creat some shorcut with any program (like VLC); or start xev
3. Press any QuickPlay button

Actual Results:
nothink

Expected Results:
key assigning to command

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >