Mailinglist Archive: opensuse-bugs (6633 mails)

< Previous Next >
[Bug 535769] New: libQtCore.so.4.5.2: Accessing a corrupted shared library
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 31 Aug 2009 15:49:52 -0600
  • Message-id: <bug-535769-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=535769


Summary: libQtCore.so.4.5.2: Accessing a corrupted shared
library
Classification: openSUSE
Product: openSUSE 11.1
Version: Final
Platform: x86-64
OS/Version: openSUSE 11.1
Status: NEW
Severity: Normal
Priority: P5 - None
Component: KDE4 Workspace
AssignedTo: kde-maintainers@xxxxxxx
ReportedBy: gassauer@xxxxxxx
QAContact: qa@xxxxxxx
Found By: ---


Created an attachment (id=316079)
--> (http://bugzilla.novell.com/attachment.cgi?id=316079)
backtrace crash from Koo

User-Agent: Mozilla/5.0 (compatible; Konqueror/4.3; Linux) KHTML/4.3.0
(like Gecko) SUSE

ldd libQtCore.so.4.5.2
/usr/bin/ldd: line 116: ./libQtCore.so.4.5.2: Accessing a corrupted shared
library

-rwxr-xr-x 1 root root 2347824 2009-08-30 15:44 libQtCore.so.4.5.2
from
http://download.opensuse.org/repositories/KDE:/Qt/openSUSE_11.1

Koo https://code.launchpad.net/openobject-client-kde
crashes printing and saving files

so I started examening the so files and this one is reported to be corrupted.

happens with KDE 4.3 on 11.0 and 11.1

koo.py --debug
<unknown program name>(8698)/ ClientApp::doIt: Creating ClientApp
/usr/lib64/python2.6/site-packages/Koo/Rpc/Rpc.py:163: DeprecationWarning:
BaseException.message has been deprecated as of Python 2.6
faultCode = err.message
ASSERT: "d->parent" in file
/hd/sdb1/daten/downloads/src/soprano-2.3.0/soprano/filtermodel.cpp, line 139
KCrash: Application 'koo.py' crashing...
sock_file=/home/kdesvn/.kde4/socket-cc-gf2/kdeinit4__0



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >