Mailinglist Archive: opensuse-bugs (6633 mails)

< Previous Next >
[Bug 535113] kiwi: removable flag not set on external usb disks, confuses kiwi
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 28 Aug 2009 08:06:37 -0600
  • Message-id: <20090828140637.EE01DCC7CD@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=535113

User ms@xxxxxxxxxx added comment
http://bugzilla.novell.com/show_bug.cgi?id=535113#c1


Marcus Schaefer <ms@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |NEEDINFO
Info Provider| |mmeeks@xxxxxxxxxx
Summary|oemboot mis-detection |kiwi: removable flag not
| |set on external usb disks,
| |confuses kiwi




--- Comment #1 from Marcus Schaefer <ms@xxxxxxxxxx> 2009-08-28 08:06:36 MDT ---
the image you created is an install stick if I read that correctly.
The boot code for the install procedure searches for a USB stick or
for a CD/DVD. Normally these are the medias an installation can start
from. Now in your case you run the installation from an external disk
connected via USB and this disk doesn't report itself as a removable
devices which seems to be wrong by the device itself

Well I think we could remove the check for the removable flag because
kiwi checks the written mbr ID to identify the correct installation
device but I thought it would be a good idea not to search all storage
devices of the system in case of an installation procedure

What do you think, how "special" is your use case ? :-)

Thanks

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References