Mailinglist Archive: opensuse-bugs (6633 mails)

< Previous Next >
[Bug 535091] New: lsb-release requires /etc/SuSE-release
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 28 Aug 2009 05:09:41 -0600
  • Message-id: <bug-535091-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=535091


Summary: lsb-release requires /etc/SuSE-release
Classification: openSUSE
Product: openSUSE 11.2
Version: Factory
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: vuntz@xxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---


The lsb_release program requires /etc/SuSE-release to work fine, apparently.
But it's not required by the package. This is an issue when building packages
that require lsb_release and depend on its output.

vuntz@lyon ~/>strace -f -e trace=open lsb_release -i -s
[...]
[pid 6907] open("/etc/SuSE-release", O_RDONLY|O_LARGEFILE) = 3
[...]

vuntz@lyon ~/>rpm -q --requires lsb-release
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
/bin/sh
rpmlib(PayloadIsLzma) <= 4.4.2-1

vuntz@lyon ~/>rpm -q --whatprovides /etc/SuSE-release
openSUSE-release-11.2-1.49

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
This Thread
  • No further messages