Mailinglist Archive: opensuse-bugs (6630 mails)

< Previous Next >
[Bug 530440] New: mysterious delay in processing of DNS replies in aria2c
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 12 Aug 2009 09:48:43 -0600
  • Message-id: <bug-530440-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=530440


Summary: mysterious delay in processing of DNS replies in
aria2c
Classification: openSUSE
Product: openSUSE 11.2
Version: Factory
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: poeml@xxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---


Here's a case of funny timeouts of 5-6 seconds happening with DNS lookups done
by aria2c. It happens on Factory (zypper dup from today).

I have collected quite some debugging info from the user who observed it. From
what I saw, it doesn't look like a problem in DNS setup. Indeed, from looking
at strace and tcpdump it seems that DNS replies are sent rather immediately
from the nameserver, but aria2c still keeps polling for data. Another
peculiarity is that each DNS lookup seems to happen twice.

The symptom is that aria2c seems to sleep for e.g. 10 seconds before starting
to download stuff. Could be seen with both aria2c 1.4.1 and 1.5.1.

The same doesn't seem to be reproducible with wget, host, curl.

Also, it doesn't happen on other systems:
- openSUSE 11.0
- openSUSE Factory from mid of June
- openSUSE Factory from mid of June, after zypper dup from today (still the old
system running)

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >