Mailinglist Archive: opensuse-bugs (6630 mails)

< Previous Next >
[Bug 530346] New: squidGuard built without LDAP support
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 12 Aug 2009 07:04:46 -0600
  • Message-id: <bug-530346-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=530346


Summary: squidGuard built without LDAP support
Classification: openSUSE
Product: openSUSE 11.1
Version: Final
Platform: i586
OS/Version: openSUSE 11.1
Status: NEW
Severity: Enhancement
Priority: P5 - None
Component: Network
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: aevseev@xxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---


User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.0.12)
Gecko/2009071200 SUSE/3.0.12-0.1.2 Firefox/3.0.12

squidGuard complains in log "syntax error" on line, containing ldapusersearch,
but not ldapbinddn and ldapbindpass.

ldd on squidGuard binary not showing linked LDAP libraries.

Spec file of squidGuard-1.3-57.66 (from source repository) contains string
"--with-ldap=/usr", but LDAP in not linked. After change this string to simple
"--with-ldap" squidGuard built with LDAP support.


Reproducible: Always

Steps to Reproduce:
1. Configure squidGuard to use LDAP (ldapusersearch)
2. (Re-)Start squid

Actual Results:
squidGuard's log contains "synatx error" on correct line in config file with
ldapusersearch

Expected Results:
URL-rewrite should be based on group membership from LDAP (Active Directory)

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups