Mailinglist Archive: opensuse-bugs (6630 mails)

< Previous Next >
[Bug 477833] Feature Proposal/Request: Add Ability to explicitly choose driver-extension for wpa_supplicant
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 12 Aug 2009 05:51:36 -0600
  • Message-id: <20090812115136.7D1E5245514@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=477833

User mt@xxxxxxxxxx added comment
http://bugzilla.novell.com/show_bug.cgi?id=477833#c10





--- Comment #10 from Marius Tomaschewski <mt@xxxxxxxxxx> 2009-08-12 05:51:35
MDT ---
I think the new code is easier to read than the patch:

test -n "$WIRELESS_WPA_DRIVER" && \
WPA_DRIVER="$WIRELESS_WPA_DRIVER" || \
case "${DRIVER}" in
prism54)
WPA_DRIVER=prism54
PREFER_WPA_SUPPLICANT=no
;;
ipw2200|ipw2100|ipw3945|hostap_*)
WPA_DRIVER=wext
;;
ndiswrapper|*.sys)
WPA_DRIVER=wext
;;
rt2500usb|rt2500pci)
WPA_DRIVER=wext
;;
rt61pci|rt73usb|rt2400pci)
WPA_DRIVER=wext
;;
iwlagn|iwl3945|iwl4965)
WPA_DRIVER=wext
;;
zd1211rw)
WPA_DRIVER=wext
;;
ath5k|ath9k|ath_pci)
WPA_DRIVER=wext
;;
b43|b43legacy|ssb)
WPA_DRIVER=wext
;;
p54pci|p54usb)
WPA_DRIVER=wext
;;
at76*)
WPA_DRIVER=wext
;;
*)
WPA_DRIVER=unsupported
PREFER_WPA_SUPPLICANT=no
;;
esac

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >