Mailinglist Archive: opensuse-bugs (6597 mails)

< Previous Next >
[Bug 527423] New: i915: kernel modesetting no longer works with kernel-default-base-2.6.30.2-1.1.x86_64
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 2 Aug 2009 10:22:40 -0600
  • Message-id: <bug-527423-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=527423


Summary: i915: kernel modesetting no longer works with
kernel-default-base-2.6.30.2-1.1.x86_64
Classification: openSUSE
Product: openSUSE 11.2
Version: Factory
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Kernel
AssignedTo: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: seife@xxxxxxxxxx
QAContact: qa@xxxxxxx
CC: mhopf@xxxxxxxxxx, sndirsch@xxxxxxxxxx
Blocks: 433520
Found By: Development


after upgrading to FACTORY on 2009-07-30 to
kernel-default-base-2.6.30.2-1.1.x86_64, i915.modeset=1 produces a black screen
on the internal LCD of an hp Compaq 2510p

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960
Integrated Graphics Controller (rev 0c)
00:02.0 0300: 8086:2a02 (rev 0c)

The display does not come back when the X server starts up. The X server does
start up, however (confirmed by KDE login sound etc.)

I was not able to verify this with an external display (no hardware at hand).

The kernel that was installed before and which worked fine with i915.modeset=1
was kernel-default-2.6.30-8.3.x86_64 (installed from FACTORY on 2009-07-08)

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >