Mailinglist Archive: opensuse-bugs (4173 mails)

< Previous Next >
[Bug 514747] New: Older Asus laptop don't work well with module acpi_laptop
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 19 Jun 2009 08:31:35 -0600
  • Message-id: <bug-514747-21960@xxxxxxxxxxxxxxxxxxxxxxxx/>
http://bugzilla.novell.com/show_bug.cgi?id=514747


Summary: Older Asus laptop don't work well with module
acpi_laptop
Classification: openSUSE
Product: openSUSE 11.1
Version: Final
Platform: i686
OS/Version: openSUSE 11.1
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Kernel
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: peter-mailbox@xxxxxx
QAContact: qa@xxxxxxx
Found By: ---


User-Agent: Mozilla/5.0 Gecko/2009042700 Firefox/3.0.10

Hello,

I've have an old Asus laptop L3D (L3000D) which worked quite well in the past
with acpi4asus and module asus_acpi.
All extra buttons on laptop and laptop-keyboard and both leds (wled for wlan
and mled for mail) worked more or less out of the box with extra scripts to
make the events do something.
With module asus_laptop, first the button 'LCD/Monitor/TV Switch' (Fn+F8) don't
work, but from acpi_listen I can see the events.
Then, I can't see any of the leds, neither in /proc nor /sys. The only maybe
led related things I can see is /sys/devices/platform/asus-laptop/wlan (and
ledd), but it's not possible to write on it (no permissions set on wlan or
ledd).
echo 1 > /sys/devices/platform/asus-laptop/wlan gives: Permission denied
and after changing the permissions to read/write
echo 1 > /sys/devices/platform/asus-laptop/wlan gives: Input/output error

I use actually
openSUSE 11.1
Kernel 2.6.27.23-0.1-pae
KDE 3.5.10 "release 21.9"

The laptop is recognized by the module asus_laptop like
asus-laptop: Asus Laptop Support version 0.42
asus-laptop: L3D model detected

Maybe this is similar to bug 448004?

Cheers

Peter

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups