Mailinglist Archive: opensuse-bugs (4172 mails)

< Previous Next >
[Bug 504424] opensuse 11.1 yast update bug
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 16 Jun 2009 09:01:36 -0600
  • Message-id: <20090616150136.8A29724550D@xxxxxxxxxxxxxxxxxxxxxx>
http://bugzilla.novell.com/show_bug.cgi?id=504424

User ma@xxxxxxxxxx added comment
http://bugzilla.novell.com/show_bug.cgi?id=504424#c22


Michael Andres <ma@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEEDINFO |NEW
Component|libzypp |YaST2
Info Provider|ingo_a_wolf@xxxxxx |
AssignedTo|zypp-maintainers@xxxxxxxxxx |bnc-team-screening@xxxxxxxx
|o.novell.com |ovo.novell.com
QAContact|qa@xxxxxxx |jsrain@xxxxxxxxxx




--- Comment #22 from Michael Andres <ma@xxxxxxxxxx> 2009-06-16 09:01:35 MDT ---
This looks like a gtk backend bug to me:

Frame 0: /usr/lib64/liby2.so.2 log_backtrace()
Frame 1: /usr/lib64/liby2.so.2 signal_handler(int)
Frame 2: /lib64/libc.so.6 [0x7fdde994f6e0]
Frame 3: /usr/lib64/YaST2/plugin/libpy2gtk.so.2 Ypp::Node::child()
Frame 4: /usr/lib64/YaST2/plugin/libpy2gtk.so.2
Ypp::Impl::polishCategories(Ypp::Package::Type)
Frame 5: /usr/lib64/YaST2/plugin/libpy2gtk.so.2
Ypp::Impl::getPackages(Ypp::Package::Type)
Frame 6: /usr/lib64/YaST2/plugin/libpy2gtk.so.2
Ypp::QueryPool::QueryPool(Ypp::QueryPool::Query*, bool)
Frame 7: /usr/lib64/YaST2/plugin/libpy2gtk.so.2
PackageDetails::setPackages(PkgList const&)




Workaround:

According to the testcase, the system seems to be sane. You should be able to
use zypper to install the QT-backend:

zypper in yast2-qt-pkg

Afterwards 'yast2 --qt' should work.

--
Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >