Mailinglist Archive: opensuse-bugs (12871 mails)

< Previous Next >
[Bug 462639] access permissions for scsi scanners missing
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 27 Jan 2009 12:57:56 -0700 (MST)
  • Message-id: <20090127195756.4F0F5245390@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=462639

User dieter.jurzitza@xxxxxxxxxxx added comment
https://bugzilla.novell.com/show_bug.cgi?id=462639#c60


Dieter Jurzitza <dieter.jurzitza@xxxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|RESOLVED |REOPENED
Resolution|FIXED |




--- Comment #60 from Dieter Jurzitza <dieter.jurzitza@xxxxxxxxxxx> 2009-01-27
12:57:54 MST ---
Hi folks,
I think this is not all that needs to be done here. If you kindly look into my
patches - well, might sound penetrant now - there is an additional line that
should go into 70-scanner.fdi that says:

<match key="@info.parent:scsi.model" string="C6270A">
</match>

specifically for Johannes' 6200C device. And I had had asked on the hal list
whether or not it would be acceptable to open any device that stems from HP (or
EPSON) promoting itself "processor" and assign it the property "scanner".
Well, nobody commented on that but I think it is not a good idea to do so.

You can argue now that this will only happen if you readily connected the
scanner - however, it can.

Therefore the key shown above should be added and it can be extracted from
/proc/scsi/scsi.

This is what latest sane-desc.c cares for.
Take care



Dieter

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >