Mailinglist Archive: opensuse-bugs (12986 mails)

< Previous Next >
[Bug 466484] on shutdown the home-partition does not clearly unmount.
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 20 Jan 2009 03:15:40 -0700 (MST)
  • Message-id: <20090120101540.7DD57245390@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=466484

User werner@xxxxxxxxxx added comment
https://bugzilla.novell.com/show_bug.cgi?id=466484#c24


Dr. Werner Fink <werner@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |NEEDINFO
Info Provider| |ro@xxxxxxxxxx




--- Comment #24 from Dr. Werner Fink <werner@xxxxxxxxxx> 2009-01-20 03:15:38
MST ---
Hmmm ... the file systems /proc and /sys are virtual file systems and
indeed they exist only in the memory and only if a directory or file
will be opened from a user space application. If /proc and /sys are
not mounted the mount point should be empty ... we could replace the
simple test for the directorieas by something like

test $(stat -f -c '%T' /proc) = proc || mount -n -t proc proc /proc
test $(stat -f -c '%T' /sys) = sysfs || mount -n -t sysfs sysfs /sys

as this would avoid buggy mount points.

Rudi? What do you think about? AFAICS on openSuSE 11.1 and SLES11 we
have /bin/stat and with this we could do this very simple.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References