Mailinglist Archive: opensuse-bugs (13042 mails)

< Previous Next >
[Bug 465122] Removal try for "powerdevil" results in unexpected reactions
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 10 Jan 2009 15:30:32 -0700 (MST)
  • Message-id: <20090110223032.DCD0ECC7CD@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=465122

User Markus.Elfring@xxxxxx added comment
https://bugzilla.novell.com/show_bug.cgi?id=465122#c3





--- Comment #3 from Markus Elfring <Markus.Elfring@xxxxxx> 2009-01-10 15:30:31
MST ---
It would be better to show a bit more about the meanings for these keys.

Continue? [Y/n/p/?]: p
Resolving package dependencies...
2 Problems:
Problem: powerdevil-lang-1.4.1-16.4.x86_64 requires powerdevil = 1.4.1, but
this requirement cannot be provided
Problem: kdebase4-workspace-4.1.3-160.1.x86_64 requires powerdevil, but this
requirement cannot be provided

Problem: powerdevil-lang-1.4.1-16.4.x86_64 requires powerdevil = 1.4.1, but
this requirement cannot be provided
uninstallable providers:
powerdevil-1.4.1-4.3.i586[Haupt-Repository_(OSS)_11.1
powerdevil-1.4.1-16.13.i586[KDE4_Core]
powerdevil-1.4.1-16.13.x86_64[KDE4_Core]
Solution 1: Following actions will be done:
deinstallation of powerdevil-lang-1.4.1-16.4.x86_64
deinstallation of compiz-kde4-0.7.8-20.1.x86_64
deinstallation of kdeartwork4-screensaver-4.1.3-18.13.x86_64
deinstallation of kde4-plasma-addons-4.1.3-42.17.x86_64
deinstallation of kde4-superkaramba-4.1.3-35.7.x86_64
deinstallation of kde4-ktux-4.1.3-17.13.x86_64
deinstallation of kde4-knewsticker-4.1.3-48.7.x86_64
deinstallation of kdebase4-4.1.3-60.6.x86_64
deinstallation of kde4-kget-4.1.3-48.7.x86_64
deinstallation of kde4-kate-4.1.3-32.7.x86_64
deinstallation of kdebase4-session-4.1.3-26.2.x86_64
deinstallation of kdebase4-openSUSE-11.1-83.3.x86_64
deinstallation of kdebase4-workspace-branding-openSUSE-11.1-83.3.x86_64
deinstallation of kdebase4-openSUSE-lang-11.1-83.3.x86_64
deinstallation of kdebase4-nsplugin-4.1.3-60.6.x86_64
Solution 2: keep powerdevil-1.4.1-4.4.x86_64
Solution 3: Ignore some dependencies of powerdevil-lang


I wonder why the zypper command wants to delete software components like Compiz
and Kate. I do not see a direct relationship to the application that I want to
be removed only.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References