Mailinglist Archive: opensuse-bugs (12871 mails)

< Previous Next >
[Bug 438867] no scanner access permissions via HAL
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 9 Jan 2009 10:23:44 -0700 (MST)
  • Message-id: <20090109172344.68371245391@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=438867

User juergen.helmers@xxxxxxxxx added comment
https://bugzilla.novell.com/show_bug.cgi?id=438867#c61





--- Comment #61 from Juergen Helmers <juergen.helmers@xxxxxxxxx> 2009-01-09
10:23:43 MST ---
Hi!

Exact same here. THis is aloop of two closed bugs with no solution for the
problem. I was waiting for new packages as well but that might take some time
longer? As far as I am concerned there is no solution for this behaviour at
this point. The scanner device on my system belongs to root.root as well. I
have added my user to group lp but even if I chgrp the scanner usb device to
"users" my user can't see or use the scanner:

as root:

#lsusb:
Bus 005 Device 002: ID 04b8:011f Seiko Epson Corp. Perfection 1670

#getfacl /dev/bus/usb/005/002
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/005/002
# owner: root
# group: root
user::rw-
group::r--
other::r--

#chgrp users /dev/bus/usb/005/002

#getfacl /dev/bus/usb/005/002
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/005/002
# owner: root
# group: users
user::rw-
group::r--
other::r--

as regular user:

#sane-find-scanner -q
found USB scanner (vendor=0x04b8, product=0x011f) at libusb:005:002

#scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Cheers Juergen


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >