Mailinglist Archive: opensuse-bugs (13048 mails)

< Previous Next >
[Bug 463464] sane-backends package cannot be build from source rpm
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 5 Jan 2009 02:24:53 -0700 (MST)
  • Message-id: <20090105092453.35C8C245390@xxxxxxxxxxxxxxxxxxxxxx>
https://bugzilla.novell.com/show_bug.cgi?id=463464

User dieter.jurzitza@xxxxxxxxxxx added comment
https://bugzilla.novell.com/show_bug.cgi?id=463464#c2





--- Comment #2 from Dieter Jurzitza <dieter.jurzitza@xxxxxxxxxxx> 2009-01-05
02:24:52 MST ---
Well, I have been diving a little further into this. Two points here:

1.) IMHO there is too much sed-magic in the spec-file. Nothing against sed, but
I think we've got that much that I decided to do some adaptations - look and
see whether you like it.

2.) IMHO there is no need to treat USB scanners different from SCSI scanners
and vice versa. Therefore I did some more:
-> change permissions to 0660 root.lp for both types of scanner devices (other
people do not need access anyway)
-> add a logic that detects scsi-scanner devices - but no magic for
autodetection, just set permissions owner and group accordingly.

To wrap up: with this each scanner interface, be it USB, SCSI or lp is treated
in the same manner and has the same owner, group and permissions, what makes
sense from a consisitency point of view.

A part of the sed-magic has been moved into sane-desc.c, this is where it
belongs IMHO.


Dieter Jurzitza


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References