Mailinglist Archive: opensuse-bugs (13056 mails)

< Previous Next >
[Bug 463327] New: Yast sets extended partition to type 83
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 2 Jan 2009 13:37:34 -0700 (MST)
  • Message-id: <bug-463327-21960@xxxxxxxxxxxxxxxxxxxxxxxxx/>
https://bugzilla.novell.com/show_bug.cgi?id=463327


Summary: Yast sets extended partition to type 83
Product: openSUSE 11.1
Version: Final
Platform: i686
OS/Version: openSUSE 11.1
Status: NEW
Severity: Major
Priority: P5 - None
Component: YaST2
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: opensuse-j@xxxxxxxxxxx
QAContact: jsrain@xxxxxxxxxx
Found By: Community User


New install of openSuSE 11.1 (DVD, automatic setup) on first partition of a
Toshiba Satellite Pro M10 laptop (with 5 partitions on it: 1:openSuse
11.0/ext3, 2:openSuSE 11.0/ext3, 3:Swap, 4:extended, 5:Data/ext3) will always
change partition 4 to type 83 (linux), while it should only mount partition 5
on mountpoint /data.
After finish of install partition 5 was deleted and partition 4 was unusable.
All data on /data were lost!!!
Partitions 2 and 3 were not touched and are ok.

Yast showed up that it would set partition 4 to type 83, but going back to
prevent this was unsuccessful. Editing of partition 4 was not allowed because
of "extended type"! Going forward lead into the same message that partition 4
will be set to type 83 and beside the other normal behavior partition 5 would
be mounted on /data.
While the installation process I recognized that partition 5 was lost and
partition 4 was really set to 83, but was not more mountable.
fsck.ext2 Message: "Attempt to read block from filesystem resulted in short
read while trying to open /dev/sda4. Could this be a zero-length partition?"

Rgds,
Juergen


--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >